Blocks

Facility to Moodle 2 database issue

 
Picture of Oliver Cooper
Facility to Moodle 2 database issue
 

Hi,

Wondering if anyone has any experience with this block... we've been using the original version of this block on 1.9 but want to move to 2.2. The server is win server 2008 R2 running IIS 7, this particuar moodle is running on MySQL. The block is installed and I've configured it accordingly (ldapcapture also installed and working) but everytime I try to do anything with it, it gives me an error about no PHP MSSQL capabilities not being installed - this is not correct as I've had a MS SQL based moodle running on the same server, I've also seen this error on our other install before and it was totally unrelated to the actual problem, it seems to be just throwing the only error it has at me.

 

Basically I don't think it's even trying to talk to the facility database and I'm a bit confused as to if my configuration is correct as all documentation is for the previous version which seems to connect to the db in a different way. (server/db/auth all in a config file, whereas it seems I need to add the db as a data source on the server with this one).

 

I have created a SQL Server system DSN in ODBC sources, set it to the correct database on our MIS server, inserted the STUD_ADMIN details and tested within the data sources (works) then for the data source in the f2m config I've entered the name of that data source. I have also tried creating a file DSN and pointing the data source to the path of this - no luck. I don't think the block is actually even hitting the ODBC driver as running a trace in data sources while attempting to fetch student data in moodle doesn't even generate a log file.

 

Am I being stupid and missing something really obvious or should that all work? Bit perplexed as to why I can't configure it as before without needing to fuss with DSNs.

 

Any help is much appreciated. smile

 
Average of ratings: -
Picture of Marc Coyles
Re: Facility to Moodle 2 database issue
 

The config is no different across versions, it's just rather than editing the config files directly, you now add the info via the GUI and the config file is assembled from that. The backend hasn't changed in the slightest - core code updated to meet the new moodle coding style where possible and to access the new Database API within Moodle, but that's it. The same data goes in the same holes within the GUI setup as went in the similarly named config fields (if you check the config files themselves, all those entries are still there, they just drag their content thru from moodle's GUI-based system).

Have you installed & configured FreeTDS? It's always been a prerequisite as far as I know...

See http://docs.moodle.org/23/en/Installing_MSSQL_for_PHP, but the entry needs to contain details for your facility server / database.

 

 

 
Average of ratings: -
Picture of Oliver Cooper
Re: Facility to Moodle 2 database issue
 

Legend, thanks so much - working now with freetds. smile

 
Average of ratings: -