General help

 
 
Picture of Lê Hoa`n
Re: 2.3.1
 

Hi Ken, 

now, i have some problems, when moved to other server, i can not upload any file on system. I had a error : 

"can not read file, either file does not exist or there are permission problems"

And then, i changed from suggestions of you

chown apache:apache * -R

chmod ugo+rw * -R.

But i have an another error: 

"can not create local file pool directories, please verify permissions in dataroot"

Althought i set permission for moodledata directory: 777.

Can you help this problem? 

Thanks.

you can see from image which i captured.


 
Average of ratings: -
Picture of Ken Task
Re: 2.3.1
Group Particularly helpful Moodlers

The item highlighted behind the error message looks to be a mount point of a remote server?  What is B...NMTH?

The items in your file picker/uploader don't look complete.  Where is 'upload a file'?

'spirit of sharing', Ken

 


 
Average of ratings: -
Picture of Lê Hoa`n
Re: 2.3.1
 

Thanks for reply, 

i renamed "Upload a file" to" BaigiangNMTH", but i can't upload any file on system. 

 


 
Average of ratings: -
Picture of Ken Task
Re: 2.3.1
Group Particularly helpful Moodlers

@ Lê Hoa`n

"moved" to a different server.  Server is what OS?

uname -an

If CentOS 6.x/RedHat Enterprise 6, is SELINUX running?

/usr/sbin/sestatus

if output of above shows:

Current mode:                   enforcing

it is on and might be the reason.  Change from 'enforcing' to 'permissive':

nano /etc/selinux/config

# SELINUX= can take one of these three values:
#    enforcing - SELinux security policy is enforced.
#    permissive - SELinux prints warnings instead of enforcing.
#    disabled - SELinux is fully disabled.
SELINUX=permissive

Reset of SELINUX requires restart of system.

Were *all* the files/folders in moodledata moved to the new server?

From /var/www/ of old server:

scp moodledata root@newserver:/var/www/

When using scp as above moodledata gets tagged as belonging to root:root.

moodledata is located in /var/www/ apache already has access to that location.

Logged on as root user new server:

cd /var/www/

chown apache:apache moodledata -R

chmod ugo+rwx moodledata -R

Check your apache access/error logs.

If all those checkout, turn on debugging.

'spirit of sharing', Ken

 
Average of ratings: -
Picture of Lê Hoa`n
Re: 2.3.1
 

Hi Ken, 

Thank you so much, i check again my server and use your suggestions. My server works very well. 

Thanks. 

 
Average of ratings: -