Installation help

 
 
Carol walking in the Howgills
upgrade stops! Moodle 2.2.2 to Moodle 2.3.3 on Ubuntu 10.04.1
 

My upgrade keeps stopping!  First tried upgrading to 2.3.4 but was advised that 2.3.3 was recommended by our supplier of integration with school MIS system

I'm upgrading my test server before trying on my live server.  I've tried upgrading at command line then tried using web browser (Firefox) then went back to command line.  Each time I fail, it takes me over an hour to restore my database from backup sad

I did find that the charset of my database was incorrect (because I'd restored from backup of live server into a new database and left collation as default) but now that's fixed.

When i start the upgrade with cli, I can find the process and it starts using maybe 7% of CPU but this gradually drops to zero over the next half hour.  Whichever way I start, I end up stuck with the message: "Site is being upgraded, please retry later."

Has anyone found a solution to this, or indeed a way to tell my moodle it's not being upgraded any more so I can start again without restoring the entire database?

thanks!

 
Average of ratings: -
Picture of Bret Miller
Re: upgrade stops! Moodle 2.2.2 to Moodle 2.3.3 on Ubuntu 10.04.1
Group Particularly helpful Moodlers

When you use the CLI to upgrade (php admin/cli/upgrade.php --non-interactive), it should display messages about what it's doing while it is upgrading. It would help to know WHERE it stops actually doing something.

 
Average of ratings: -
Picture of Ken Task
Re: upgrade stops! Moodle 2.2.2 to Moodle 2.3.3 on Ubuntu 10.04.1
Group Particularly helpful Moodlers

Since you are already experiencing frustration, the following may not relieve that ... just yet.  First of all, does the 'school MIS system' integration add to/change any Moodle code?

Have all the 'tweaked' settings for PHP and MySQL that may exist on the production server been applied to the test system?  Even if they have, think uping them ... more time to execute a script in PHP, amount of memory the PHP script can consume (as examples) ... because the process of upgrading is intensive. 

Might check test server's apache error log now to see if there is anything useful there.

Think making a duplicate of the existing production server on the test server AND upgrading that to the highest version in the 2.2.x series (2.2.6+) might need to be done first.  That's easily done with git and all one needs off the production server is the config.php file, the moodledata directory, and, of couse, an sql import (editing the config.php file and the sql dump before importing).

'an hour'?!  That's a rather large sql dump file!  Is your development/test server in a virtual environment?  If so, up the memory on it.  In addition, turn on logging for MySQL and make sure apache is also logging to error.log.

On the test server, take the debug lines from the config-dist.php file and paste them into the copied and edited for new location config.php file before attempting upgrade.  That, hopefully, will render some information should the move to the highest 2.2.6+ have issues.

Get that working first then (via git) upgrade the 2.2.6+ to the 2.3.3+.

Sorry, don't see any 'easy button' here! :|

'spirit of sharing', Ken

 
Average of ratings:Useful (1)
Carol walking in the Howgills
Re: upgrade stops! Moodle 2.2.2 to Moodle 2.3.3 on Ubuntu 10.04.1
 

Thanks very much Ken and Bret.  All useful advice.  The command line upgrade never got beyond the  first output of --> system but as it turns out, my upgrade finally ran when I left it overnight, having shut down apache and started at the command line.  

I will be turning on mysql logging and binary log in the hope of speeding up restore times that way.  I do wonder if my database has some issues because it is not as fast as it might be as well as taking a long time to restore.  My moodle has been running for about 4 years and has 500 courses.

Carol

 
Average of ratings: -