Installation help

 
 
Picture of Darlene Murphy
Getting FastCgi message
 

I am tryying to install Moodle.  Have done it before, but now for some reason I am getting the following: Your installation has failed because php-cgi.exe is not available.  Please return to the windows installer and enable either "FastCGI" or "Other CGI" option.

How do I fix this problem.  PHP is installed via iis and I can see the php-cgi.exe in the folder.

Thank you

LadyDee

 
Average of ratings: -
moi!!! it is what is is...
Re: Getting FastCgi message
Group Documentation writersGroup Particularly helpful Moodlers

Have a look at your php.ini file and make sure that the fast-cgi option is enabled and is pointing to the right path. ... From memory, there was another aspect too that needs to be enabled, or it needed to be enabled at two points. (Haven't used iis for a very long time, not a patch on apache.tongueout )  

 
Average of ratings: -
Picture of Darlene Murphy
Re: Getting FastCgi message
 

I am still getting the same error.  I am now getting the following:

DownloadManager Information: 0 : Adding product 'Moodle' to the cart
DownloadManager Warning: 0 : product.SelectedInstaller == null for: PHP53ForIISExpress
DownloadManager Information: 0 : Starting install sequence
DownloadManager Information: 0 : Using cached file at C:\Users\Administrator\AppData\Local\Microsoft\Web Platform Installer\installers\Moodle\a9dd9a95e29c8f821f2005f8b8675281b1ff8f38\MoodleWindowsWpi-latest-23-20121121.zip instead of downloading from http://download.moodle.org/download.php/direct/windows_wpi/MoodleWindowsWpi-latest-23-20121121.zip
DownloadManager Information: 0 : Testing database connection string
DownloadManager Information: 0 : Using connection string: 'server=localhost;database=moodle715;uid=root'
DownloadManager Information: 0 : Setting DeploymentBaseOptions.WebServerDirectory: C:\Program Files (x86)\IIS Express
DownloadManager Information: 0 : Setting DeploymentBaseOptions.ConfigurationDirectory: C:\Users\Administrator\Documents\IISExpress\config
DownloadManager Information: 0 : Setting DeploymentBaseOptions.WebServerDirectory: C:\Program Files (x86)\IIS Express
DownloadManager Information: 0 : Setting DeploymentBaseOptions.ConfigurationDirectory: C:\Users\Administrator\Documents\IISExpress\config
DownloadManager Information: 0 : Moodle installation log: C:\Users\Administrator\AppData\Local\Microsoft\Web Platform Installer\logs\install\2012-12-09T13.46.01\Moodle.txt

 
Average of ratings: -
Picture of Darlene Murphy
Re: Getting FastCgi message
 

I still have not been able to get Moodle to install because of this error.  Any solutions?  Can you uninstall applications from IIS when you are using the server?

LadyDee

 
Average of ratings: -