General help

 
 
Picture of Marta Blasco
Bad appearance
 

Hi,

I've just installed Moodle 2.3.2 in my computer. It's my first time I use it. It's appearence is very bad. It doesn't show the icon images. I've changed the theme and it doesn't appear (you can see in the image).  

I've been reading a lot and I can't find what problem I have, perhaps I've to change something of my configuration but I don't know what.

Can anybody help me. Thanks

 
Average of ratings: -
Picture of Alan Hess
Re: Bad appearance
Group Particularly helpful Moodlers

Hello

This is a common problem which is often caused by incorrect domain information in the config.php file.

We need to know more about your system. Are you accessing the Moodlesite on the same computer that is hosting it? What did you use for the domainname or IP address?

The problem can also occur when migrating an existing Moodle site to a new computer.

Regards

 
Average of ratings: -
Picture of Marta Blasco
Re: Bad appearance
 

Hello,

I'm not migrating, I've just installed for the first time and try to learn.

During the installation the file config.php couldn't be created, so I had to do it manually, with this code:

Thanks

<?php // Moodle configuration file

unset($CFG);
global $CFG;
$CFG = new stdClass();

$CFG->dbtype = 'mysqli';
$CFG->dblibrary = 'native';
$CFG->dbhost = 'localhost';
$CFG->dbname = 'moodle';
$CFG->dbuser = 'root';
$CFG->dbpass = 'marta';
$CFG->prefix = 'mdl_';
$CFG->dboptions = array (
'dbpersist' => 0,
'dbsocket' => 0,
);

$CFG->wwwroot = 'http://localhost/moodle';


$CFG->dataroot = 'C:\\moodledata';
$CFG->admin = 'admin';

$CFG->directorypermissions = 0777;

$CFG->passwordsaltmain = '1MPh5b2~@ZCk_mNP5C`]cQQX';

require_once(dirname(__FILE__) . '/lib/setup.php');

// There is no php closing tag in this file,
// it is intentional because it prevents trailing whitespace problems!

 
Average of ratings: -
Picture of Alan Hess
Re: Bad appearance
Group Particularly helpful Moodlers

Hi Marta

You seem to have installed on a windows computer. Right?

I think the line $CFG->dataroot = C:\moodledata should be with only ONE '\' backslash in that case. This is probably what is causing your computer not to be able to find the graphic images.

Let us know if that does the trick.

Regards

 

 
Average of ratings: -
Picture of Marta Blasco
Re: Bad appearance
 

Hello,

Thanks for your answer.

You are right. It's a Windows XP computer.

I've removed one backslash but the problem persists.

 

I'm looking at different config.php I've found in internet. There is one instruction I don't have in main:

$CFG->dirroot = ‘?’;

I don't know if it's necessary, and which folder I have to indicate

 
Average of ratings: -
Picture of Alan Hess
Re: Bad appearance
Group Particularly helpful Moodlers

Hi again

No, the dirroot parameter was used in Moodle v1.9. I don't think it's necessary with Moodle v2+

Are you sure your moodledata directory is at C:\\moodledata ?  I've always installed Moodle on Linux Systems personally but I've just downloaded and unzipped the most recent windows package 2.4 and the standard data directory is at C:\server/moodledata .

However the auto installation failed first time for me too. If I've time, I may try to repair the installation later. In the meantime check where your moodledata directory actually is on the hard drive.

Regards

 

 

 
Average of ratings: -
Picture of Marta Blasco
Re: Bad appearance
 

Hello again,

Yes, I'm sure. I've reinstalled several times Moodle for this reason. For uninstall I've removed 2 folders:

- c:\moodledata

- c:\inetpub\wwwroot\moodle

And I've removed, also, mysql table moodle

Thanks.

 
Average of ratings: -
Picture of Marta Blasco
Re: Bad appearance
 

Hi

I've uninstalled Moodle 2.3 and I've installed last version, Moodle 2.4. During the installation you can choose the folder where to copy moodledata.

I don't know what else to do. Thanks for your help

 

 
Average of ratings: -
Picture of Alan Hess
Re: Bad appearance
Group Particularly helpful Moodlers

OK - I got the package running on my XP machine. Try the following.

1) Reboot PC and delete old 'server' directory.

2) Unzip the 2.4 download file. Do not start Moodle just yet!

3) Make sure you change the permissions on the 'server' directory to 'NOT write protected'. Click with the RH mouse button on 'server' and uncheck the write protect box. Include subdirectories option in the change.

4) Now start Moodle (XAMMP) and run the installation process. 

The installation seems to fail if the write protection is not removed.

Hope that helps.

 

 

 
Average of ratings: -
Picture of Marta Blasco
Re: Bad appearance
 

Hi again,

Sorry but one question, which is the server directory? Is c:\inetpub\wwwroot\moodle?

When you say "Click with the RH mouse button". What does RH mean?

Sorry for my poor english.

 
Average of ratings: -
Picture of Marta Blasco
Re: Bad appearance
 

Ok. I've done all you've said. Now any error during the installation. But the image icons doesn't appear.

 

 

 
Average of ratings: -
Picture of Alan Hess
Re: Bad appearance
Group Particularly helpful Moodlers

Hi

Sorry about the abbreviation. RH = Right Hand (button).

I downloaded the newest 2.4 windows pack from the moodle site here http://download.moodle.org/windows/

The zip file created just one directory called C:\server  and two files to start and stop Moodle.  All the XAMPP and Moodle files are within this directory on my version.

Your 'inetpub' directory is probably part of the Microsoft Internet Publisher package. I'm not sure if this was part of your older windows download or if you have it from some other application. It could be conflicting with the newer download.

Can you try the new download file out on a different computer without c:\inetpub ? This would help to find out.

Regards

 
Average of ratings: -
Picture of Marta Blasco
Re: Bad appearance
 

Hi,

I downloaded, yesterday, the version of Moodle you told, but I couldn't install it. I supose the problem coud be a conflict between Apache and IIS, localhost must be different, I believe.

This morning I'll try again.

Thans for your help

 
Average of ratings: -
Picture of Alan Hess
Re: Bad appearance
Group Particularly helpful Moodlers

Yes, that could be it. If you already have IIS on your computer, then maybe try downloading the standard Moodle software package. You will of course, have to configure MYSQL, PHP and IIS yourself.

There is some info on this for v2 here

 
Average of ratings: -
Picture of Marta Blasco
Re: Bad appearance
 

Hi,

For this reason, I uncompresse the standard Moodle, then I copy the Moodle folder in c:\inetpub\wwwroot. From here I run install.php

The only problem I've got is the images. I think MySQL runs ok because I can create different users, with password, and they are/saved in users table

Later I'll try again.

Thanks

 
Average of ratings: -
Picture of Marta Blasco
Re: Bad appearance
 

Hi,

I've reinstalled all again. Also I've upgrade IIS from version 5.1 to 6. And same problem.

When I see the properties of the images that I can't see, the link is this:

http://localhost/moodle/theme/image.php/standard/core/1355156725/i/navigationitem

I can't understand this link, and it doesn't exist. I've searched in the folder moodle, I can't find 5 navigationitem images in four different folders:

- C:\Inetpub\wwwroot\moodle\pix\i

- C:\Inetpub\wwwroot\moodle\theme\brick\pix_core\i

- C:\Inetpub\wwwroot\moodle\theme\magazine\pix_core\i

- C:\Inetpub\wwwroot\moodle\theme\mymobile\pix_core\i

Does anybody understand this?

Thanks

 
Average of ratings: -
Picture of Alan Hess
Re: Bad appearance
Group Particularly helpful Moodlers

Hi Marta

Don't worry too much about the strange link. Moodle 2 uses a special file manager system which seems to generate dynamic virtual addresses. Unlike Moodle v1 it is very difficult to locate program and data files manually in this way. I think it has been done for security reasons. Can someone explain why? I'd be interested to know too.

I'm sorry I can't help you with IIS, I'm really only experienced in Linux but hopefully there is someone out there who can help? 

Do you have a Windows Network Server? Is that the reason you are using IIS? 

 
Average of ratings: -
Picture of Marta Blasco
Re: Bad appearance
 

Hi Alan,

The reason to use IIS is an old ASP web I wrote and still works, sometimes I have to do some updates.

Thanks

 
Average of ratings: -
Picture of Alan Hess
Re: Bad appearance
Group Particularly helpful Moodlers

Hello Marta

As no one wih IIS knowledge seems to be helping here, you could repost your problem in the following forum - Windows Based Servers

https://moodle.org/mod/forum/view.php?id=6799

Hopefully you will get some more assistance there. Repeat as much info about your system and the installation steps you've taken as you can.

Sorry I couldn't help you more.

Regards from Snowy Switzerland

 

 
Average of ratings: -
Picture of Marta Blasco
Re: Bad appearance
 

Hi Alan,

Thanks very much for your help. I'm looking for information in Google, for the moment I've found any solution.

I'm going to take a look to the link you have sent.

Thanks very much.

Marta

 
Average of ratings: -
Picture of Marta Blasco
Re: Bad appearance
 

Hi Alan,

Finally I've solved the problem. I've uninstalled php and installed EasyPHP, I think it uses apache instead of iis.

Now the appearence of Moodle is good.

Thanks for your help.

Marta

 
Average of ratings: -
You either love it or you hate it
Re: Bad appearance
Group Particularly helpful Moodlers

I ws going to suggest using apache. IIS is horrid and you will encounter endless issues for all of time if you use IIS

 

Albert

 
Average of ratings: -
Picture of Marta Blasco
Re: Bad appearance
 

Thanks

 
Average of ratings: -