Installation help

 
 
Picture of pinguas pinguim
Problems with upgrading moodle to 2.4... help dependencies...Urgent
 

Hello folks,

 

I am with a problem on moodle upgrading 2.3 to 2.4.

 

I have this dependencies problems plugins warning.

 

Dependencies check failed for filter_data, filter_glossary, workshopallocation_scheduled

Nome do pluginDiretórioFonteVersão atualNova versãoRequerStatus
Filter Text
Disable automatic links /filter/data Default 2011102800 2012112900
  • Moodle 2012112900
  • mod_data (2012112900)
To be updated
Automatic links to the glossary  /filter/glossary Default 2011102801 2012112900
  • Moodle 2012112900
  • mod_glossary (2012112900)
To be updated

Laboratory Evaluation / Methods of allocation submissions
  Scheduled allocation / mod / workshop / allocation / Default scheduled

 Scheduled allocation /mod/workshop/allocation/scheduled Padrão   2012112900
  • Moodle 2012112900
  • workshopallocation_random (2012112900)
To be installed

You must resolve all plugins requirements before proceeding with the installation of this version of Mood
 
Average of ratings: -
Picture of David Mudrák
Re: Problems with upgrading moodle to 2.4... help dependencies...Urgent
Group DevelopersGroup Documentation writersGroup Moodle HQGroup Particularly helpful MoodlersGroup Translators
Hi. There must be something wrong with the way how you uploaded Moodle 2.4 files to your web server. Are you sure that you have moved the old 2.3 files and uploaded the new 2.4 ones? See http://docs.moodle.org/24/en/Upgrading#Install_the_new_Moodle_software
 
Average of ratings:Useful (2)
Picture of Mike Sangray
Re: Problems with upgrading moodle to 2.4... help dependencies...Urgent
 

I'm having the same problem. I tried upgrading from both 2.3.1 and 2.3.3 and got the same error. It must be a problem with the upgrade process or there is something wrong with the download or repository.

I'm on CentOS and I am using git to grab the download.

I'm staying on 2.3.x until this is resolved.

This is my post that contains the same error. See my 2nd post with a screenshot. https://moodle.org/mod/forum/discuss.php?d=217265

Mike

 
Average of ratings: -
Picture of David Mudrák
Re: Problems with upgrading moodle to 2.4... help dependencies...Urgent
Group DevelopersGroup Documentation writersGroup Moodle HQGroup Particularly helpful MoodlersGroup Translators

Hi Mike

both before and after you checkout the MOODLE_24_STABLE branch, can you please check the files mod/data/version.php, mod/glossary/version.php and mod/assign/version.php and look at what is their $module->version value?

Also, if possible, can you execute the following two SQL queries and then post all the results here?

# SELECT * FROM mdl_config WHERE name='version';
# SELECT name, version FROM mdl_modules;

I still believe it is a local issue. Although there may be a bug, of course.

 
Average of ratings: -
Picture of Mike Sangray
Re: Problems with upgrading moodle to 2.4... help dependencies...Urgent
 

/mod/data/version.php $module->version = 2012061700

/mod/glossary/version.php $module->version = 2012061700

/mod/assign/version.php $module->version = 2012061700

 

mysql select results

mdl_config version 2012032501.05

mdl_modules

'assign', '2012061700'

'assignment', '2012061701'

'book', '2012061700'

'chat', '2012061700'

'choice', '2012061700'

'data', '2012061700'

'feedback', '2012061700'

'folder', '2012061700'

'forum', '2012061700'

'glossary', '2012061700'

'imscp', '2012061700'

'label', '2012061700'

'lesson', '2012061700'

'lti', '2012061700'

'page', '2012061700'

'quiz', '2012061701'

'resource', '2012061700'

'scorm', '2012061701'

'survey', '2012061700'

'url', '2012061700'

'wiki', '2012061700'

'workshop', '2012061700'

'attforblock', '2011071601'

'turnitintool', '2012060801'

'questionnaire', '2012082001'

 

 
Average of ratings: -
Picture of Mike Sangray
Re: Problems with upgrading moodle to 2.4... help dependencies...Urgent
 

I've tried disable selinux, but that didn't help. I'm a bit stuck here. Any ideas?

 
Average of ratings: -
Picture of Mike Sangray
Re: Problems with upgrading moodle to 2.4... help dependencies...Urgent
 

It looks like both the /filter/data and /filter/glossary version.php files have $plugin->dependencies = array('mod_data' => 2012112900); lines that other version.php files do not have.

I commented out the dependency line in the /filter/data/version.php file and it no longer appears as a dependcy check when doing the moodle upgrade.

Are the dependency lines needed in these version.php files? If not, is it safe to just comment them out and proceed with the upgrade?

Mike

 
Average of ratings: -
Picture of Mike Sangray
Re: Problems with upgrading moodle to 2.4... help dependencies...Urgent
 

Hm...well the upgrade complete successfully, but now I'm getting this when I login to the site:

"Coding error detected, it must be fixed by a programmer: PHP catchable fatal error"


 
Average of ratings: -