Installation help

 
 
Franck Chionna
moodle 2.3 and 2.4 installation error
 

after upgrade modules and clicked on continue button I get

 

Installation must be finished from the original IP address, sorry.

 

I'm sure there is no IP modification on my network.

2.4 does the same

 

Thanks

 
Average of ratings: -
Picture of Howard Miller
Re: moodle 2.3 and 2.4 installation error
Group DevelopersGroup Documentation writersGroup Particularly helpful Moodlers

Which operating system? Which database (and version)? Which version of PHP?

Where did you get the Moodle code from and how are you installing it? Did you do *anything* related to the IP address either in Apache or Moodle's config.php? I'm thinking any trickery to compensate for internal/external network access or the like.

 
Average of ratings: -
Franck Chionna
Re: moodle 2.3 and 2.4 installation error
 

Linux Fedora 10 and 17, postgresql 9.2.1, php 5.3.8

moodle code grab from moodle.org installed from web apache server.

First of all, I had to modify manually lib/dml/pgsql_native_moodle_database.php

to change the default port to 6432, weirdly the dboptions["port"] has no effect in config.php

about the IP problem, maybe it comes from the virtual IP I use in my cluster. I use Haproxy that redirect a virtual ip to a backend server with another IP.

But I never had this kind of problem until version 2.3

 

Regards

 
Average of ratings: -
Picture of Howard Miller
Re: moodle 2.3 and 2.4 installation error
Group DevelopersGroup Documentation writersGroup Particularly helpful Moodlers

So you have load balancing? Multiple Moodle front-ends then?

Personally, I would complete the install on one front-end only.

 
Average of ratings: -
Franck Chionna
Re: moodle 2.3 and 2.4 installation error
 

Apparetnly I have no choice....

but the 2.3 doc didn't describe it on the matter

 
Average of ratings: -
Picture of Howard Miller
Re: moodle 2.3 and 2.4 installation error
Group DevelopersGroup Documentation writersGroup Particularly helpful Moodlers

Where are you looking?

 
Average of ratings: -
Franck Chionna
Re: moodle 2.3 and 2.4 installation error
 

You mean ?

 
Average of ratings: -
Picture of Visvanath Ratnaweera
Re: moodle 2.3 and 2.4 installation error
 
Average of ratings: -
Franck Chionna
Re: moodle 2.3 and 2.4 installation error
 

I limited my load balancing with only one backend server and it's the same.

Maybe version 2.3 does not include reverse proxy method htat manage obviously different backend IP.

But anyway, I'm a moodle plugin developer so I would need to run version 2.3 and 2.4 to update my plugins.

 

Regards

 
Average of ratings: -