General plugins

Blank page when trying to enable Poodll repository

 
 
Picture of P H
Blank page when trying to enable Poodll repository
 

Hello,

I have downloaded the PoodLL Kaboodle version 2.3.8 (2012110500) and installed it on Moodle 2.3.3.

The installation went on smoothly. I set up the Poodll filter and activated it. But then when I tried to enable Poodll repository, I got a blank page. I used the browser's back button to go back to Manage Repositories page which showed (after refresh) that Poodle repository was still disabled. Tried again - and again - with the same result. (That's one definition of insanity if my memory serves me right: "doing the same thing over and over again and expecting different results".) ;)

Here is the error message:

Fatal error: Cannot make static method repository::instance_config_form() non static in class repository_poodll in SITE_URL/repository/poodll/lib.php on line 805

Any idea what has caused the problem and how it can be sorted out?

Thanks,

P. H. 

 
Average of ratings: -
Picture of Justin Hunt
Re: Blank page when trying to enable Poodll repository
Group Particularly helpful Moodlers
Hi P H, Yes I know what causes that problem. The repository API changed in Moodle 2.3, and I we had to make separate versions for Moodle 2.2 and Moodle 2.3. (Something similar happened in the 2.2 assignment too.) So that means there is a PoodLL Kaboodle for Moodle 2.1/2.2 and a separate one for Moodle 2.3 I think you have installed the PoodLL Kaboodle for Moodle 2.2 into Moodle 2.3. I'm sorry it happened, but it is easy enough to fix. Just download the 2.3 version from here: http://poodll.com/downloads-for-poodll-2-3/ You can just take the PoodLL Kaboodle or, just the repository and 2.2 assignment mods. I hope it solves it for you.
 
Average of ratings: -
Picture of P H
Re: Blank page when trying to enable Poodll repository
 

Thank you very much for the prompt reply!  

Am I right to assume that I should overwrite the existing Poodll folders with the news ones, then go to the notification page and reinstall them? Or wouldn't that be necessary? 

Sorry to be bothering you on a Sunday. 

P. H. 

 
Average of ratings: -
Picture of Justin Hunt
Re: Blank page when trying to enable Poodll repository
Group Particularly helpful Moodlers
Yes thats right, just overwrite the old stuff. The versions will be the same so Moodle probably won't notice the difference. It will just start working.
 
Average of ratings: -
Picture of P H
Re: Blank page when trying to enable Poodll repository
 

I did so and the problem got sorted out. Thanks again for the advice. (Silly of me to have mixed up the two packages in the first place, but that's what happens when you are still working at 3 am on a Sunday...)

But now I have another problem. When I record and insert an audio file into an html area, I have two players. 

At first, for a fraction of a second, I get a glimpse of this:

And then it is replaced with this: 

Have I got anything wrong again? 

P. H. 

P.S. It's on Chrome by the way.

 
Average of ratings: -
Picture of Justin Hunt
Re: Blank page when trying to enable Poodll repository
Group Particularly helpful Moodlers

The player you see for a fraction of a second is Chrome's HTML5 MP3 player. (It is actually really good. ) But it is being replaced by the standard Moodle flowplayer, via the Multimedia plugins filter. That is normal if you use the Multimedia plugins filter.

The player below is  PoodLL's player. What is happening is that both the Multimedia Plugin filter and the PoodLL filter are filtering the same text, so you end up with two players. The PoodLL filter tries to prevent double filtering, but it has to be higher in the filter list than the multi media plugin.

You can set that on the site-administration's Manage filter settings page, as in the screenshot I attached. I didn't realise that was occurring so I am glad you alerted me to it.


There are other options available, such as turning off mp3/flv handling in either of the two filters, but just moving PoodLL to the top is probably the easiest way.


Sorry for the hassle.


 
Average of ratings: -
Picture of P H
Re: Blank page when trying to enable Poodll repository
 

 
Hello and thanks again for the explanation. 

The Poodll filter was already higher in the filter list than the multimedia filter when I took those screenshots. 

For the moment I have solved the problem by disabling the standard multimedia filter's handling of mp3 files. 

A couple of things to ask and suggest: 

  1. Have you considered replacing the PoodLL player, before you click on it, with something more aesthetically pleasing? ;)
  2. There's quite a bit of background noise after recording. I have played with audio gain without much success. Any suggestions perhaps? 
  3. I would like to set the length of the player in percentages rather than in pixels. How could that be achieved? 

Thanks again, 

P. H. 

  

 
Average of ratings: -
Picture of Justin Hunt
Re: Blank page when trying to enable Poodll repository
Group Particularly helpful Moodlers

Hmm, thats worrying about the double filtering. If you send me a message with the url and an admin login, perhaps I could peek at the settings and see whats up.

You can turn off the big black "splash" screen for the audio so that the player loads immediately, ie without waiting for the click. In the PoodLL filter settings page, under Flowplayer settings, just uncheck "Show Simple Audio splash." The big black splash thing is not especially aesthetically pleasing, its true. (It is possible to load a separate splash, let me know if that is a better solution for you.)

If you wish to get mildly funky you can also set the color of the player, in the same section under Flowplayer Color.

The background noise is probably more to do with your mic and PC and the recording codecs, then the PoodLL settings. Apart from tweaking the gain levels, I am not sure much can be done at the settings level.  I've also noticed when using the "PoodLL MP3 recorder" there does seem to be more noise. If you use the original "PoodLL audio recorder", which records via tokyo.poodll.com, you may get better quality recordings. (By default that records to FLV, so you might get double filtered again ...)

 

Unfortunately right now the player sizes are pixel based only. That probably won't change in the near future.

 

 

 

 
Average of ratings: -
Picture of P H
Re: Blank page when trying to enable Poodll repository
 

 

You needn't worry. For whatever reason it works fine now. I don't know what did it as I made several changes, but you could take your pick between:  

  1. Purging the cache
  2. Disabling the default mp3 in "media embedding"  and enabling it again. 
  3. Disabling mp3 handling in Poodll filter and enabling it again. 

Also, I removed the splash screen and it looks much nicer to me now. (As a mere suggestion, you could perhaps consider disabling the splash screen as the default choice?)

As to background noise, I'll try to use a different computer/microphone and let you know later. 

Thanks again for taking the time to help me resolve the issues. 

Have a good day! 

P. H. 

 

 
Average of ratings: -
Picture of Justin Hunt
Re: Blank page when trying to enable Poodll repository
Group Particularly helpful Moodlers

OK thats great. Thanks for hanging in there. And I am glad it is working

Yes I could remove the black box splash as a default. For the record, it is there to speed up and stabilize things on slower browsers when showing pages with multiple flowplayers. 

 
Average of ratings: -
Picture of P H
Re: Blank page when trying to enable Poodll repository
 

Hello Justine, 

I am back with a problem.

The mp3 audio recorder seems to be very unpredictable. I have tested it on 4 computers. On a Windows 7 laptop and a Windows 7 netbook the recording quality is acceptable, but on a MacBook Pro and a Desktop Mac, the quality is really poor, the recorded sound is full of interruptions (a couple per second) that make the result barely understandable. 

Any suggestions as what may be the cause? 

P. H. 

 
Average of ratings: -
Picture of P H
Re: Blank page when trying to enable Poodll repository
 

I think I'll take back my suggestion about not making the splash the default as it sometimes takes several seconds for the player to appear even though it is not a slow connection. But perhaps a more elegant one would be in order? 

Thanks! 

P. H. 

 
Average of ratings: -
Picture of Justin Hunt
Re: Blank page when trying to enable Poodll repository
Group Particularly helpful Moodlers

Roger that. One reason it takes ages to load is that Moodle encourages us all to delay the javascript and loading until everything else has loaded. They cheat on their own flowplayer though and load it before other peoples stuff.( I may get flamed for saying that ...)

Regarding audio quality, it seems to be a little dependant on people's hardware. In my own tests, Mac and PC, the standard audio recorder(via Red5 tokyo.poodll.com) gives a little better quality. But others report a more marked difference. One setting that can interfere is the "Silence Level" setting. If it is too high, low volume sounds can be regarded as silence and the recording can be patchy. There is little problem in setting it to zero, so that is probably best.

 
Average of ratings: -
Picture of P H
Re: Blank page when trying to enable Poodll repository
 

Hello again Justin, 

Two things:

  1. I have attached an image file that I suggest you use as splash in the future versions if you like. 
  2. I have also attached a short audio file to give you an idea of the recording quality on a (quite new) MacBook Pro. As you see it is really poor. However, I get acceptable quality on a simple "netbook". Could it have something to do with Macs as opposed to PCs by any chance?
  3. Silence level was set to 1 (one). I have set it to 0 (zero) now and will keep you posted of any possible effect.

Have a good day, 

P. H.

P.S. I couldn't attach two files. I'll attach the audio file separately. 


 
Average of ratings: -
Picture of P H
Re: Blank page when trying to enable Poodll repository
 

And here is the audio file. 

 
Audio file (MP3)
Average of ratings: -
Picture of Justin Hunt
Re: Blank page when trying to enable Poodll repository
Group Particularly helpful Moodlers

Thanks for the image file. I've stopped adding more and more features and stuff recently, and I'm going back trying to fix up all the little things that I never get around to doing. So improving that splash will be one if them. 

yeah that recording is rough  isn't it. It is not a straight out Mac issue, because it works nicely on my Mac mini. I'm sure it is hardware related.  But I am just not confident enough to point the finger at any one thing.  But I would not be surprised if a USB mic on the same Mac would give better quality. Actually come to think of it, I use a blue yeti USB mic on my Mac mini. 

You might try toggling the echo suppression and loop back fields on the recorder settings tab. There is also a hardware acceleration check on the flash settings dialog when you right click the recorder. Do any of those improve things? 

If I could reproduce the problem myself I wouldn't have to guess. Sorry. 

 

 
Average of ratings: -
Picture of Justin Hunt
Re: Blank page when trying to enable Poodll repository
Group Particularly helpful Moodlers

I just tried it on my Mac mini by plugging in my iPhone headset earphones to the audio out jack (Mac mini has no mic in jack, only line in, that's different). Recording was fine. Things got weird though if the "rate" setting was not 44, I sounded chipmunk'ed. 

 
Average of ratings: -
Picture of P H
Re: Blank page when trying to enable Poodll repository
 

Hello Justine, 

Just to report that we continue to esperience problems on two of our students' MACs. They use Skype on their computers with no problems at all but when it comes to audio recording through Poodll, the result is as I have posted above. 

I have also been unable to find a setting for video recording with an acceptable quality. 

Have a good day! 

P. H. 

 
Average of ratings: -
Picture of Justin Hunt
Re: Blank page when trying to enable Poodll repository
Group Particularly helpful Moodlers

Can you send me, by email, a student login, and the url of a video and audio activity on your site that I can test with?

Justin

 
Average of ratings: -
Picture of Justin Hunt
Re: Blank page when trying to enable Poodll repository
Group Particularly helpful Moodlers

When you have these problems recording with Macs, could you take down a little information for me? In particular the Mac OS version, the flash player version and the browser type and version? 

Also it would be helpful to know which recorder you are using when you get these problems ... the PoodLL mp3 recorder or the standard PoodLL audio recorder. Does one or the other give different results?

 

Thanks

 
Average of ratings: -
Picture of P H
Re: Blank page when trying to enable Poodll repository
 

Hello, 

Here is what one of our members has sent me: 

- Your Mac OS version  OS X version 10.8
- Your browser type and version Chrome Version 23.0.1271.95
- Your flash version: Flash is set up but I can't find any information on it
 
Have a good day! 
 
P. H. 
 
Average of ratings: -
Picture of P H
Re: Blank page when trying to enable Poodll repository
 

I can report a good-quality recording using Safari on the same Mac (the above) where we had a very low-quality recording using Chrome. 

 
Average of ratings:Useful (1)
Picture of Justin Hunt
Re: Blank page when trying to enable Poodll repository
Group Particularly helpful Moodlers

Aha. Well that confirms that it is probably a chrome + mac issue.

I think ti will be hard to solve at the poodll level, but playing with the chrome flash player settings as described here might help.

http://www.howtogeek.com/103292/how-to-fix-shockwave-flash-crashes-in-google-chrome/

 
Average of ratings:Useful (1)
Picture of P H
Re: Blank page when trying to enable Poodll repository
 

Of course! I'll send you an email with the access details. 

P. H. 

 
Average of ratings: -