Moodle for mobile

 
 
Picture of Andrew C
Re: Problem accessing moodle from ipad2
 

Hi, I've also obtained a similar message in a forum on the mobile browser. (iPhone 4s)

I clicked on News forum, 'Add new topic', "IO FATAL".

After clicking ok twice and I ignore this - then works fine. The formatting of the new discussion distorts. It is only when the Message box loads up do I experience the problem.

After looking at the PHP error logs, I get:

 

 PHP Notice:  Undefined variable: bodyclasses in C:\x\theme\mymobile\layout\embedded.php on line 50
 PHP Warning:  join(): Invalid arguments passed in C:\x\theme\mymobile\layout\embedded.php on line 50
 Default exception handler: Can not find data record in database table course. Debug: SELECT * FROM {course} WHERE id = ?
[array (
  0 => 6182,
)]
* line 1272 of \lib\dml\moodle_database.php: dml_missing_record_exception thrown
* line 1249 of \lib\dml\moodle_database.php: call to moodle_database->get_record_select()
* line 66 of \file.php: call to moodle_database->get_record()Default exception handler: Can not find data record in database table course. Debug: SELECT * FROM {course} WHERE id = ?
[array (
  0 => 6182,

I'm testing on a Moodle 2.2.5 and to be honest - this test area has been quite heavily modified already so it maybe this particular install.

I'll open up the PHP file and see if there is anything logical in there. I'm also wondering if its because I'm using an Admin account.

 

Thanks,

Andrew

 

 
Average of ratings: -
Picture of Susan Fleming
Re: Problem accessing moodle from ipad2
 

I have also had a report of this popping up from a teacher who is marking forum posts on her ipad - unfortunately I don't have an ipad so haven't been able to duplicate the error.  From the information provided, this is more an irratant than something that interfers with functionality.

We are on version 2.2.4

Susan

 
Average of ratings: -