General ESMJ Forum

Bulk Upload Creates Mojibake

 
画像 Don Hinkelman
Bulk Upload Creates Mojibake
 
Whenever I bulk upload students, the student names become mojibake.  How can avoid this? 

I create and save the excel file as CSV comma delimited using Microsoft Excel Japanese version.  When I use roman characters, no problem to bulk upload.  When I use kanji or katakana, it is destroyed.
 
評点平均: -
画像 Minoru Akiyama
Re: Bulk Upload Creates Mojibake
 
Hi Don,

You'd better to use Hidemaru editor to convert DBCSs from Shift_JIS to EUC-JP.

# I'm looking forward to meet you at JALT CALL 2005.smile

Minoru Akiyama
e-Learning Service LPC.


画像 Mitsuhiro Yoshida
Re: Bulk Upload Creates Mojibake
DevelopersTranslators
I also recommend you to use "SAKURA editor".

1. Open your csv file with Sakura editor.
2. Save your file again with EUC-JP or UTF-8 depending on which character set you are using on your Moodle site.

Please make sure to backup your csv file before converting its encoding.

[ Text Editor "SAKURA"]
http://sakura-editor.sourceforge.net/
Pensive mood
Re: Bulk Upload Creates Mojibake
 
Hi Don,

Not sure if this will help. However, if you have access to the apache config file, you could try adding this to your stanza:

 <IfModule mod_php4.c>
php_value default_charset UTF-8
php_value mbstring.language Japanese
php_value mbstring.detect_order auto
php_value mbstring.http_input pass
php_value mbstring.http_output pass
php_value mbstring.internal_encoding UTF-8
php_value mbstring.substitute_character none
php_value mbstring.func_overload "0"
php_flag mbstring.encoding_translation Off
</IfModule>

Also an .htaccess modification will do the same, if the apache settings will allow you to do so. You can take a look at this for more info.

http://codewalkers.com/phpdocs/ref.mbstring.html

Bill