Testing and QA

MyISAM to InnoDB - Cannot switch off Theme designer mode

 
 
Picture of Peter Birdsall
MyISAM to InnoDB - Cannot switch off Theme designer mode
 

I posted a problem regarding not being able to switch off Theme designer mode after upgrading from Moodle 2.2 to moodle 2.3. (see my post earlier this week: http://moodle.org/mod/forum/discuss.php?d=212192

Our main moodle installation dates back through all upgrades to 2004, so to try and find out what happened I tested it on a fresh install that was upgraded from 2.1 through 2.2 to 2.3. In the move from 2.2 to 2.3 the system advises to change the database from MyISAM to InnoDB. 

This I did, using the built in moodle script - then updated cvs to the latest 2.3 version and immediately the theme was lost and no theme shows correctly at all without turning Theme designer mode on.

 

 
Average of ratings: -
Picture of Peter Birdsall
Re: MyISAM to InnoDB - Cannot switch off Theme designer mode
 

Today I have tried to see if it is something to do with the cache:

  • Manually deleted the cache in the data dir
  • Checked permissions
  • Cleared cache in e-accelerator

Nothing works. Themes only show in Designer Mode on, otherwise the site just shows a list of html, like in this post:

http://moodle.org/mod/forum/discuss.php?d=168281

So back to my first conclusion that this happened when we changed the tables from MyISAM to InnoDB 

Not sure how changing the database type could affect the theme..

 
Average of ratings: -
Picture of Mauno Korpelainen
Re: MyISAM to InnoDB - Cannot switch off Theme designer mode
 

Peter,

 I visited your site a minute ago and there is one "tip" in your site source that expains it all - pagespeed. It's an apache module that some sites use for minimizing javascripts and it messes up yui combo javascript (that moodle is using for combining css files)

See http://moodle.org/mod/forum/discuss.php?d=210673 and also

http://moodle.org/mod/forum/discuss.php?d=208552#p918405

If it is your server you can simply uninstall mod_pagespeed or on hosted environment ask your host to change site settings so that your site does not use mod_pagespeed.

 
Average of ratings: -
Picture of Peter Birdsall
Re: MyISAM to InnoDB - Cannot switch off Theme designer mode
 

Hello Mauno

Thanks for your feedback. Yes, I installed mod_pagespeed to try and help the reduction in performance / speed after upgrading to 2.3.

Now I have uninstalled it, but still the problem is not solved.

I always worry because our moodle has been upgraded all the way from 2004, and think that this maybe to blame, which is why I tested on a moodle install and upgrade from 2.1 through to 2.3:  http://www.wittenborg-intranet.eu/login/index.php shows what happens with designer mode off, and is an example of a system that used a new data dir and a new download of moodle.

It’s one of those things that will take some time to find I think. I remember years ago a similar problem which had to do with permissions, so have been checking those also, on cache dirs. etc.

Peter

 

 
Average of ratings: -
Picture of Mauno Korpelainen
Re: MyISAM to InnoDB - Cannot switch off Theme designer mode
 

When I compare your site source to my test site source the first row seems to be different:

<?xml version="1.0" encoding="utf-8"?>

that might break part of code.

I just don't understand where that part comes to your source mixed

Here you see the first tags of my test site and the same tags on your site

start

 
Average of ratings: -
Picture of Peter Birdsall
Re: MyISAM to InnoDB - Cannot switch off Theme designer mode
 

Yes, that is strange. However, I don't see the tag on the main "problem site" www.wittenborg-online.com - I also switched designer mode off for a moment to check if the tags changed.

 
Average of ratings: -
Picture of Peter Birdsall
Re: MyISAM to InnoDB - Cannot switch off Theme designer mode
 

We still can't switch off Theme designer mode, after looking everywhere:

first upgrade test.wittenborg.eu works fine (September)

www.wittenborg-online.com can't switch off (since start October)

 
Average of ratings: -
Picture of Gilles Gagnon
Re: MyISAM to InnoDB - Cannot switch off Theme designer mode
 

Peter.. did you ever get this resolved?

I have a similar problem... css gone whenn Designer mode is off.

CHeers,
Gilles

 
Average of ratings: -
Picture of Peter Birdsall
Re: MyISAM to InnoDB - Cannot switch off Theme designer mode
 

Hello Gilles

No we are still faced with the problem. I have tried everything within my basic understanding to try and solve. I am sure its a database issue.

We have gone to far to go back to using the September backup version, (student paper uploads, news, etc) so will have to find the solution.

Will keep this area informed when we get it solved.

Regards, Peter

 
Average of ratings: -
Picture of Gilles Gagnon
Re: MyISAM to InnoDB - Cannot switch off Theme designer mode
 

Thanks for getting back to me Peter.

I guess our situations are a bit different.  The ISP switched things around, new SQL, PHP and Apache. I didn't switch db engine like you.


However, our symptoms are the same. What's strange is that if the "open up" security, I can see the site perfectly without turning on "theme designer mode". The ISP can't figure out which setting at their end is causing the CSS to "be turned off"/not seen when designer mode is turned off and the security setting of the site are normally set.

Gilles

 
Average of ratings: -
Picture of Peter Birdsall
Re: MyISAM to InnoDB - Cannot switch off Theme designer mode
 

I have solved our issue! I still have no idea what caused it, but it is database related.

What I did is this:

I switch off designer mode and put site into maintainance mode, then dumped the database using phpmyadmin.

Then I created a new empty database, and imported the dump.

Now the site works as it should, showning normally with designer mode off.

Database problem, thus - but no idea what the cause is.

 
Average of ratings: -
Picture of Gilles Gagnon
Re: MyISAM to InnoDB - Cannot switch off Theme designer mode
 

Fantastic!  Congrats!


My issue is different, although the symptom is the same. I may have to start a new thread. First, I'll wait to see what the ISP comes back with.

Cheers,

Gilles

 
Average of ratings: -
Picture of Peter Birdsall
Issue not solved: Re: MyISAM to InnoDB - Cannot switch off Theme designer mode
 
Issue not solved: I have now discovered what action causes this to happen in the first place: Clear theme cache = site (css) only shows in designer mode "on" So we are back to square 1. Only short term solution is to again copy the database and try again and leave the cache as it is. So problem is this: clearing cache causes css / them to stop working unless Theme designer mode is left on. short term workaround: Theme designer mode can be left switched off again if the moodle database is imported into a new database. BUT Clearing Cache will revert back to the problem.. .. anyone with ideas would be very welcome.
 
Average of ratings: -
Picture of Gilles Gagnon
Re: Issue not solved: Re: MyISAM to InnoDB - Cannot switch off Theme designer mode
 

Interesting... Perhpas we do have the same issue after all. I wonder if yours is also related to some security/permissions as well. Have you tried "opening security" (as stated by my ISP... whatever this means) to see if your problem goes away as well. If so, it narrows down the possibilities.

 

I wonder if it all has to do with some perms/secuirty with the location/ownership, etc of the cache folder?

 
Average of ratings: -
Picture of Gilles Gagnon
Re: Issue not solved: Re: MyISAM to InnoDB - Cannot switch off Theme designer mode
 

My issue was finally resolved. Hopefully the solution therein will help others. My ISP made the changes "removed the following from disable_functions list":

Readfile

Ini_set

Set_include_path

From what I understand this was set in the php.ini file.

Cheers,

 
Average of ratings: -
QED
Re: Issue not solved: Re: MyISAM to InnoDB - Cannot switch off Theme designer mode
 

Since this is the last post in this long thread I assume this resolved the issue for everyone? Tonight my themes went missing and would only return if I turned on Designer mode. It didn't matter what theme I was using. Can anyone confirm this solution?

 
Average of ratings: -