Gradebook

 
 
Picture of Debbie Unterseher
Missing Course Total (Moodle 2.3.1)
 

What am I missing here?  Using Moodle 2.3.1. There are no hidden items in the gradebook or the course page.  I took out the categories to see if that would fix things.  The grader report has no overridden cells.  There just is no course total showing at all.  So far it's just this course.  One interesting note.  It was pulled over from 1.9 and the teacher had set up his own Letter scale.  And I saw it the other day when I went there.  Included decimal places.  Now its back to the default Letter scale.

Picture of Debbie Unterseher
Re: Missing Course Total (Moodle 2.3.1)
 

Fixed it by changing the Course aggregation to Sum of Grades.  It then displayed a calculator by the Course Total.  Still no total showing.  Then clicked on the calculator and added a simple calculation that was probably incorrect, since it showed a 0 in the course total.  Took off the calculation, and the course total appeared.  Strange...  Not sure if the professor played around with that before or what....

Picture of Debbie Unterseher
Re: Missing Course Total (Moodle 2.3.1)
 

Oh - I also change it to view one student at a time in the grader report.  Although not sure that did anything.  I just know I had tried everything the day before.

Picture of Natalie Welcome
Re: Missing Course Total (Moodle 2.3.1)
 

Initially, course totals were not appearing in my User Reports. I went to the

  1. Categories and Items tab,
  2. noticed that there was a value of zero in the Course Totals field at the bottom of the page,
  3. entered 100 to represent the course total for that class...viola! It worked.
  4. Immediately, the course totals were calculated.

It's as if the program can't perform the calculations without knowing the course total value. Rather than specifying the error, it just leaves a zero.(key words: 2.3 course totals lost, missing, not showing up, empty, blank, zero, user report)

Picture of Michele Edwards
Re: Missing Course Total (Moodle 2.3.1)
 

Miss Welcome,

Thank you so much for this excellent solution.  I just encountered the "zero in the Course Totals field" yesterday after removing a column calculation I had created.  I looked high and low for the cause and solution.  Just this morning, I came across your post - and this was exactly what was needed.

Best wishes for the holiday and the new year.

Michele Edwards