Installation help

 
 
Picture of James Rodewald
Upgrade from Moodle 2.0.10 to 2.1.7 -- stuck!
 

I am relatively new to the network administrator role and am stuck on why I cannot get our Moodle 2.0.10 install to upgrade to Moodle 2.1.7. 

These are the steps I am following and the error I am getting. Any guidance on how to get this to work would be greatly appreciated!

1. Backed up MySQl database, moodle data folder and moodle code folders

2. Using cPanel's File Manager on Siteground I renamed the current moodle folder (public_html) and created a new empty public_html folder.

3. Unzipped the latest Moodle 2.1.7+ zip in the public_html folder.

4. Copied old config.php into new public_html folder.

5. Using cPanel's PHP Version Manager on Siteground I changed the PHP version on the moodle data and public_html folders from 5.2.17 to 5.4.5.

6. Attempted to trigger the install by navigating to the www.shscience.net/admin page but received the following error.

------------

Error: Database connection failed

It is possible that the database is overloaded or otherwise not running properly.

The site administrator should also check that the database details have been correctly specified in config.php


Warning: mysqli::close(): Couldn't fetch mysqli in /home/shscienc/public_html/lib/dml/mysqli_native_moodle_database.php on line 336

-----------------------------------------

I receive exactly the same error if I just flip PHP version from 5.2.17 to 5.4.5 in cPanel's PHP version manager and try to use the website. I know I'm missing something obvious here.

Any guidance on how to set this straight would be greatly appreciated, and being new to this I would appreciate help in laymans terms! Thanks so much!

Regards,

J. Rodewald

 
Average of ratings: -