General help

 
 
Ray Lawrence
Re: 2.2 Forum posts sent to messaging not email
Group Particularly helpful Moodlers

Still havng an isue with this... all message output settings are set to email but posts still end up as notifications in messaging for all users.

Everythig in the database looks OK. Any ideas on where to look next appreciated.


 
Average of ratings: -
Tim at Lone Pine Koala Sanctuary
Re: 2.2 Forum posts sent to messaging not email
Group DevelopersGroup Documentation writersGroup Particularly helpful Moodlers

Those are the system-wide defaults.

I think that individual user's settings are stored as user_preferences.

 
Average of ratings: -
Ray Lawrence
Re: 2.2 Forum posts sent to messaging not email
Group Particularly helpful Moodlers

Thanks Tim. Yes, that's correct. Only few users have set messagng preferences and only one has set messaging as a preference ofr subscribed forum posts.

Further invistigations have narrowed this down to the config table and my colleague has been through the painstaking task of eliminating by comparing and changing values. After changing all probable options he started on the those less likely to have any effect.

The site is now sending out emails from forum posts... the value that needed changing to bring this about...? The support email.

That doesn't make any sense to us:

  • It's been the same email since the site was installed
  • The site has functioned correctly with the same email in place since its upgrade to 2.2.x

So we're slighlty uneasy about the apparant fix but will accept it with gratitude as were running out of ideas fast.

 
Average of ratings: -