Backup and restore

Course back up error

 
 
paula
Course back up error
Group Particularly helpful Moodlers

I am trying to backup and restore a course that was originally in 1.9 and was moved with our site when upgraded to 2.1.3.  It is giving me an error:  error/moodle/cannot finish ui if not setting ui

This is the only course I am getting this error in of the ones I have tried. There is no info on the moodle.org page about this error.  Can anyone give me any information?

Thanks,

Paula Clough cool

 
Average of ratings: -
paula
Re: Course back up error
Group Particularly helpful Moodlers

I was finally able to get the course to backup.  Would still appreciate any insight in case it happens again.

Thanks,

Paula Clough cool

 
Average of ratings: -
Picture of Ken Task
Re: Course back up error
Group Particularly helpful Moodlers

Care to share what you did differently other than TIA? ;)

Curious minds want to know!

'spirit of sharing', Ken

 
Average of ratings: -
Picture of Ken Task
Re: Course back up error
Group Particularly helpful Moodlers

As you might already know, Moodle.org is indexed by Google.  Used this Google search:  

site:moodle.org error/moodle/cannot finish ui if not setting ui

and found several hits, but none seem to have exactly the same issue nor the same solution.

The following are suggestions:

A. It could be there was a resource/mod/block whatever used in that 1.9 course that's in-compat with version 2.  If you still have the 1.9 site up, consider removing non-core mod/block items in the course.  Back it up then TIA (try it again).

If you don't have a 1.9 up and running can 'loan' you one I've up and running.  You could acquire an account and restore.  We could both inspect it then.  Contact me off list if you'd like to try that.

B. Upload the 1.9 backup to a web accessible directory.  In your 2, turn on URL repo.  Then in any course, hit restore button and choose the URL repo as method.  Copy and paste the URL to the 1.9 backup in that web directory.  At the beginning of that process it will warn about the backup not being compatible and it will try first to convert the course to a 2 version and restore.  Restore to a new course - not the one you are in.  Might loose some things ... like mods you had in the 1.9 that aren't installed in the 2 ... but, most of the course is there to begin rebuilding.

C. could unzip the backup zip and inspect the moodle.xml file for things like those addons.  One could edit the moodle.xml removing the offending items and also removing the files related or other related in the folders of the unzipped backup.

Have to zip up the edited/unzipped backup again making sure the moodle.xml file is at the root of the zip when it's unzipped.

'spirit of sharing', Ken

 
Average of ratings:Useful (1)