Installation help

 
 
Tim at Lone Pine Koala Sanctuary
Re: Problems with cli on upgrade or install moodle 2.2.1
Group DevelopersGroup Documentation writersGroup Particularly helpful Moodlers

"You can upgrade to Moodle 2.2 from ... 1.9"

That is clear. It is also correct.

 
Average of ratings:Useful (1)
Picture of Visvanath Ratnaweera
Re: Problems with cli on upgrade or install moodle 2.2.1
Group Particularly helpful Moodlers
Hi Tim,

Thanks for the confirmation. The first sentence in the quote says exactly that. But the following sentences asking to check 2.1 -> 2.2 upgrade, 2.0 -> 2.1 upgrade, etc. make one unsure. Anyway 've submitted the information to the Documentation Dept. http://moodle.org/mod/forum/discuss.php?d=193518#p843413.
 
Average of ratings: -
Tim at Lone Pine Koala Sanctuary
Re: Problems with cli on upgrade or install moodle 2.2.1
Group DevelopersGroup Documentation writersGroup Particularly helpful Moodlers

Yes. Because any important things that you must consider when upgrading from Moodle 2.0 to 2.1 are also important things that you must consider when you upgrade from 1.9 to 2.2.

So, you need to read all the release notes.

 
Average of ratings: -
Picture of Visvanath Ratnaweera
Re: Problems with cli on upgrade or install moodle 2.2.1
Group Particularly helpful Moodlers
Makes sense.

But the links I was talking about in my first post do no point to release notes but to update instructions!

Since I know the answer now, it dosen't matter to me. I hope the doc-dept will catch it for the benefit of the casual visitor.

Coming back to the original problem, I have no other ideas. "Segmentation fault" points to a severe problem in the system software. Since you're on Solaris, I wouldn't know where to start, other than recompiling the software stack.
sad
 
Average of ratings: -
Picture of Thorsten Bieser
Re: Problems with cli on upgrade or install moodle 2.2.1
 

Hallo Visvanath,

thanks for your efforts.

I tried some variations in upgrading or installing with the cli.

The best way actually (but also not working) is with an existing config.php.

The cli options for creating a config.php wont work at all

With an existing config.php you have to use 'install_database.php'

I used the $CFG->upgradeshowsql = true;  for a bit more information

The installation works now  a little better....

it creates 149 tables

and stops here:

INSERT INTO mdl_config_log (userid,timemodified,plugin,name,value,oldvalue) VALUES(?,?,?,?,?,?)
[array (
  0 => 0,
  1 => 1329210107,
  2 => NULL,
  3 => 'formatstringstriptags',
  4 => '1',
  5 => NULL,
also with an segmentation fault.

 

Btw. I agree with your suggestion that it is an OS problem. But I was hoping anyone else ist using Solaris out there....

cheers

Thorsten

 

 

 
Average of ratings: -