General help

Section out of control

 
Picture of James Thomas
Section out of control
 

Not seen this before, have you?

As you can see in the attachment, the text typed in the Section is in the left half of the space and all the modules are in the right side. Problem is, no matter what we try, the edit button for the Section is unclickable.

Further consequences of this - all the Blocks start at Section 29. Above them is "grey matter". And in the Sections below 29, the left part of each Section is also "grey matter".

Could anyone exercise their own grey matter on this for us pls.

Thanks as always,

James


 
Average of ratings: -
Mary Cooch
Re: Section out of control
Documentation writersMoodle Course Creator Certificate holdersMoodle HQParticularly helpful MoodlersTestersTranslators

Try this:

  • turn on the editing in your course
  • click on the “hand and pen” icon of a topic summary that DOES work
  • Go up to the url at the top of your screen – look at the number at the very end  in the address bar
  • It will probably be something like http://YOURMOODLESITE.com/course/editsection.php?id=12
  • The last number is the topic summary number that you are in at present. Type in different numbers near that one until you get to the topic summary that has been corrupted (don’t worry if you end up in a totally different course – just keep changing the number at the end until you get to your “broken” summary.) If you’re lucky it might only be a digit away. If you are even luckier and you only recently edited (broke!) the summary, its url might still be saved in your address bar.
  • When you get to it, delete everything by clicking on the code view icon, rather than doing it in the WYSIWYG editor. Save changes – and you should then have a working topic summary with an edit icon you can click on.
  • screencast here
 
Average of ratings: Useful (1)
Picture of Ken Task
Re: Section out of control
Particularly helpful Moodlers

While it's true one could replace numbers … guessing … until one hit the item to be edited, there is a more exacting way. (didn't say easy)

Login to Moodle site and go to the course with the issue.
In your browser, view the source
Search the source window for 'middle-column'.
That will get you to the center panel where the sections of the course are.
Then do another search of source for 'sectionblock'.
The section that has the errant item will show under sectionblock-# where # is the number of the section.
Look in that section area of code for the links to the activities/labels and their ID numbers.  The ID number is the one you plug into *another browser window* using the 'site/course/editsection.php?id=#

'spirit of sharing', Ken

 
Average of ratings: -
Picture of Glenys Hanson
Re: Section out of control
 

Hi James,

I felt like experimenting this so in a Sandbox where I only had one Section/Topic, I created a second one. I deliberately corrupted the first one by copying and pasting an Excel file into it.

  • I tried out Mary's way but when I realised that Section 2 had an ID of 214, and Section 1 could be any one of the other 213 (I tried 212 and 211 and got into different courses), I realised it could take all night.
  • So I tried Ken's way but though I found the sectionblock-1, I'm not techie enough to recognise the code for the links to labels.
  • So I used the "sweep it under the carpet" way.
    • I created far more Sections/Topics than I'm ever likely to use.
    • Turned off Ajax in my profile (it's much easier to do the next bit with the arrows)
    • Moved Section/Topic 1 to the last Section/Topic position.
    • Reset the number of Sections/Topics to what I wanted.
    • Turned Ajax back on.

So now you have 3 solutions.

Cheers,

Glenys

 
Average of ratings: -
Picture of James Thomas
Re: Section out of control
 

Thanks everyone. It was such a weird problem, one that I'd never even thought possible, let alone encountered.

It also served as a great demo of the Community for the group of sts I have at the moment who are learning to use Moodle as teachers.

 
Average of ratings: -
Picture of Chris Delaney
Re: Section out of control
 

As a non-techie, I struggled a bit with Ken's info above... so here is what worked for me. 

Our 'Topic Outline' edit icon was locked and couldn't get access due to some copy and paste action by a new Moodler!

Anyway, went to Topic 1 Summary/Outline, clicked edit noticed the URL was  

YOURMOODLESITE/course/editsection.php?id=2594

Check out Topic 2 Summary/Outline the URL was same with php?id=2595 and so on.... hopefully you can see the pattern!

So when I went back to 'id=2593' (for Topic 0 - my course Outline) I found it. Hope this helps.

 
Average of ratings: -