Moodle開発者フォーラム

プラグインチェックについて。

 
画像 福丸 雅史
プラグインチェックについて。
 

お世話になります。

試験的に/moodle/mod/quiz/overviewのoverviewディレクトリを差し替えて、新しく/moodle/mod/quiz/testというディレクトリを作成しました。とりあえずディレクトリの中身はoverviewディレクトリと同じにしてあります。

するとhomeのページでプラグインチェックという警告が出たのですが、これを解消する方法をご存知の方ご教授よろしくお願いいたします。

 
最大評点: -
画像 福丸 雅史
Re: プラグインチェックについて。
 

追記 

DDL sql実行エラーが発生しました。というエラーが出ます。

version.php、lang\en\quiz_test.php

を作るという所までは分かったのですが、その先が調べても手詰まりな状況です。

とても初歩的な質問なのかもしれませんが、最低限で良いのでどなたかご教示よろしくお願いします。

画像 Mitsuhiro Yoshida
Re: プラグインチェックについて。
DevelopersTranslators

恐らく、ディレクトリ「/moodle/mod/quiz/report/test/db/」内のファイル「install.xml」および「upgrade.php」に「/moodle/mod/quiz/report/overview/」用のデータベーステーブルの記述が残ったままになっていると思います。

「install.xml」および「upgrade.php」の記述すべてを「/moodle/mod/quiz/report/test/」用に書き換えてください。

もしよろしければ、現在お使いのMoodleのバージョン、開発環境にお使いのサーバOS等の情報をお教え頂けませんでしょうか。

#  このトピックを「新機能要望フォーラム」から「Moodle開発者フォーラム」に移動させて頂きます。


画像 福丸 雅史
Re: プラグインチェックについて。
 

yoshida様ご返答どうもありがとうございます。

「install.xml」内の全てのoverview→test

「upgrade.php」のfunction xmldb_quiz_overview_upgrade内の全てのoverview→test

に変更することでアップグレード完了しました。ご指摘有難うございました。

 

今回は

moodleバージョン

→2.2{$release  = '2.2dev (Build: 20110803)}

開発環境

→PHP 5.3.2-1ubuntu4.9 with Suhosin-Patch

→Apache/2.2.14 (Ubuntu)

→mysql  Ver 14.14 Distrib 5.1.41

を使用しております。記入忘れ申し訳ありませんでした。

画像 Mitsuhiro Yoshida
Re: プラグインチェックについて。
DevelopersTranslators

下記の開発者用ドキュメントが参考になるかと思います。

[Developer Documentation - MoodleDocs]
http://docs.moodle.org/dev/