Gradebook

 
 
Gmads
Grader report "You don't have permission" error (Moodle 1.9.13)
Group Particularly helpful MoodlersGroup Testers

Hi,

I have a school where they are just starting to use the manual grading system (to grade normal school activities). Teachers have set up categories and items, but now, after they input the grades and try to save them, they get the following error:

Forbidden
You don't have permission to access /grade/report/grader/index.php on this server.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Just to be sure, I completely reinstalled Moodle, but the same problem appeared. I also turned on debugging, but after I click on the Update button, the aforementioned error page is displayed.

Then I recreated the same essential course environment (separate groups, with groups and groupings) with a couple of students. This was done on another installation (same Moodle version) under the same site; here I didn't have any problems when saving the grades.

So, I backed up the course from the first installation and restored it on the second one. I got the same error.

Finally I restored the course on my local installation (same Moodle version), and here I was able to save the grades.

Thanks in advance for any help, it will be truly appreciated.

Guillermo

Gmads
Re: Grader report "You don't have permission" error (Moodle 1.9.13)
Group Particularly helpful MoodlersGroup Testers

Problem solved!

The problem was in the number of students enrolled in the course (18), along with a large and complex grade structure (number of categories/items used).

My test course had only 2 students and a very simple grade structure.

After an insight, I went to: Administration > Grades > Report settings > Grader report, and started to decrease the value of the "Students per page" parameter, from 100 to 10, 5, 1.

Only when I set it to display one student, I was finally able to save the changes. I then started to increase the value, and the limit was four students per page.

My original local installation test worked fine because my PHP memory and time-out settings are quite ample.

Cheers!

Picture of Arnold Lamont
Re: Grader report "You don't have permission" error (Moodle 1.9.13)
 

Hi Guillermo,

I am now experiencing the exact same problem with Moodle 2.2.2

I have about 60 graded items and 44 students in this course.  I have entered a Category comment manually by choosing Grader Report and then Edit Settings. 

Now I am unable to correct that comment or take off the 'tick' next to the 'overridden' category.

I have already decreased the 'Students per page' parameter under Administration > Grades> Report Settings>Grader report down to '1' but I still can't make the changes.

Any help would be great!

Picture of Alberto Ferreira
Re: Grader report "You don't have permission" error (Moodle 1.9.13)
 

Hello Arnold

 

Did you found the solution ?

 

Alberto