Moodle for mobile

 
 
Picture of Jérôme Mouneyrac
My Moodle App with LDAP users, still not working for you?
Group DevelopersGroup Documentation writersGroup Moodle Course Creator Certificate holdersGroup Moodle HQGroup Particularly helpful MoodlersGroup Testers

Hi,

I've been testing the My Moodle app with a LDAP server (OpenDS) and it works. The tracker issue is there: MOBILE-113
Let me know if you still have the issue.  Don't forget to test with a manual user. If it didn't work for a manual user too, it is not related to LDAP.

 
Average of ratings: -
Picture of J M
Re: My Moodle App with LDAP users, still not working for you?
 

I'm still having this issue. It works with a manual user, but not with an LDAP user. When I try to log in with the LDAP account, I get this error: "Couldn't connect: the site must be Moodle 2.1 or later." We are using version 2.1.1.

 
Average of ratings: -
Picture of Jérôme Mouneyrac
Re: My Moodle App with LDAP users, still not working for you?
Group DevelopersGroup Documentation writersGroup Moodle Course Creator Certificate holdersGroup Moodle HQGroup Particularly helpful MoodlersGroup Testers

When a LDAP user authenticate on your Moodle site, does it create a user in the Moodle database or not?

 
Average of ratings: -
Picture of J M
Re: My Moodle App with LDAP users, still not working for you?
 

Yes, it creates a local user. I've been trying to log in to the app using an account that has already been auto-created.

 
Average of ratings: -
Picture of Jérôme Mouneyrac
Re: My Moodle App with LDAP users, still not working for you?
Group DevelopersGroup Documentation writersGroup Moodle Course Creator Certificate holdersGroup Moodle HQGroup Particularly helpful MoodlersGroup Testers

Could you try the login/token.php currently in master to see if it works better ? https://github.com/mouneyrac/moodle/blob/master/login/token.php

 
Average of ratings: -
Picture of J M
Re: My Moodle App with LDAP users, still not working for you?
 

Unfortunately, that didn't work. However, I set up a test server using the latest code, with the same ldap configuration, and I was able to log in using the app. Perhaps something changed between the version I have (2.1.1+ 20110817) and the latest one (2.1.2+ 20111102)?

 
Average of ratings: -
Picture of Jérôme Mouneyrac
Re: My Moodle App with LDAP users, still not working for you?
Group DevelopersGroup Documentation writersGroup Moodle Course Creator Certificate holdersGroup Moodle HQGroup Particularly helpful MoodlersGroup Testers

Yes I saw some new LDAP code related to enrolment, I guess it's what was missing. 

 
Average of ratings: -
Picture of Anurag Singh
Re: My Moodle App with LDAP users, still not working for you?
 

I am using LDAP authentication with moodle 2.4.3 version but unable to authenticate to moodle app. It says please use higher from 2.4. Please suggest what should i do.

 
Average of ratings: -
Picture of David Perry
Re: My Moodle App with LDAP users, still not working for you?
Group Testers

Anurag, did you try logging in with a manual account as per Jerome's suggestion further up? If so, and still no joy, you'll need to create a guest login so the app's developer (Juan) can debug what's going on.

Whether the app works or not is one of the first things I will be testing when our upgrade gets done (to m2.4 in the current plan).

HTH

 
Average of ratings: -
Picture of R. T.
Re: My Moodle App with LDAP users, still not working for you?
 

Hi,

as I'm a newbie as a moodle admin I have to ask this question:

In http://docs.moodle.org/25/en/Mobile_Moodle_FAQ#I_can.27t_access_my_Moodle_site_using_the_app

it still says that the LDAP authenification doens't seem to work for Moodle 2.5 either?

And in the tracker https://tracker.moodle.org/browse/MOBILE-113, it say's that this is in progress? When will this be solved?

Our users authentified with LDAP can't log into the platform with there mobiles (but via tablets and pc it works for years), eventhough all settings for the web services are set.

We're using Moodle 2.5.3+ , with MySQL.

Cheers,

r. t.

 

 

 
Average of ratings: -