Assignment

 
 
Picture of Phil Kowalski
Have no upload button
 

Dear Moodle community.

First of all please let me say thank you for this community and for Moodle in general. It in fact is a pretty powerful tool.

However I am facing a problem I cannot solve alone therefore I kindly ask for your help. I purchased a book on how to set up Moodle for several business tasks and one of the first projects is to set up a course as support for the recruitment process in HR. The first thing there to do is to set up an assignment so the applicant can upload his resume. Therefore I used activity -> upload a single file. The text and title appear perfectly after I click save and display but not a single piece of upload button ;)

I have googled Moodle and "no upload button" as well as read through FAQs here and also searched the forum. Because the above search term is very general it didn't get back the results I need to solve the problem.

I am currently using Firefox 4 with Moodle 2.1 on my local webserver. I have the course active (meaning the submission timeframe is set from yesterday until next week) as well as ticked "allow resubmitting" to no and prevent late submissions to yes.

Can anyone help me with this? Thanks in advance!

 
Average of ratings: -
Mary Cooch
Re: Have no upload button
Group Documentation writersGroup Moodle Course Creator Certificate holdersGroup Moodle HQGroup Particularly helpful MoodlersGroup TestersGroup Translators

Hi there. Make a new account and assign it the role of student in that course and then click on the assignment - and then see if they have an upload buttonsmile Often if you don't see it then it is because either you are viewing the assignment as a teacher or you have used the "switch role to" option which doesn't always display things as they should be. If you ARE logging in  as a genuine student and you still don't see the upload button, then please post back and we can suggest some other ideas.

 
Average of ratings:Useful (2)
Picture of Phil Kowalski
Re: Have no upload button
 

okay, thanks, that solved the question. I thought that the "swith to role: student" would be good enough but obviously it needs to have a "real" user.

Thanks for your help!

 
Average of ratings: -
Picture of Dave Baron
Re: Have no upload button
 

I have just had the same issue in assignments switching role to student the upload button doesn't appear. After much banging of head on desk I came to this page and tried your suggestion of logging in with a student account and the upload button does appear. Thank you!

 
Average of ratings: -
Mary Cooch
Re: Have no upload button
 
Average of ratings: -
Picture of rachel hard
Re: Have no upload button
 

Hello,

 

I too am having this problem...however i have had students enroll and they can still NOT see this button.

 

help please!!!

 
Average of ratings: -
Mary Cooch
Re: Have no upload button
Group Documentation writersGroup Moodle Course Creator Certificate holdersGroup Moodle HQGroup Particularly helpful MoodlersGroup TestersGroup Translators

Rachel - can you give more details, for instance, version of Moodle, type of assignment and how the students are enrolled? Thanks

 
Average of ratings: -
Picture of rachel hard
Re: Have no upload button
 

Hi.

It is Moodle 2.3, the type of assignment is single file upload, and online text.

Students are self enrolled. We are currently testing moodle...and my colleagues are self enrolling to test out the course before we deliver to the public.

I hoep this gives enough info?

 
Average of ratings: -
Jon
Re: Have no upload button
Group Particularly helpful Moodlers

Yeah, I've seen this too. It's brutal. It was happening to assignments in 2.3 that were upgraded from 2.2 assignment types using the upgrade tool.

You have to open each assignment's settings and click on save. This will fix the issue.

Depending on how many assignments and how many courses I've got it down to about a 5-10 min. fix for each course.

Open the course, turn on editing mode;

Right-click on each editing icon for the assignment opening in a new tab. Do this for every assignment in the course (this saves a great deal of time so you don't have to wait for all the screen loads, saving, back and forth stuff).

Click on a tab, scroll down, click save, click on the next tab and repeat. Then you can go back and close all those tabs.

This will also fix issues where feedback entry does not show up for teachers grading the assignment.

 
Average of ratings: -
Picture of rachel hard
Re: Have no upload button
 

Thanks for the advice...but unfortunately editing and re-saving did not work.

These assignments (single file upload and online text) are newly created in Moodle 2.3.

does anyone have any more advice please and thank you??

 
Average of ratings: -
Picture of Nathan Lind
Re: Have no upload button
 

Correct, the issue is for new assignments and for imported assignments, both.

 
Average of ratings: -
Picture of Eric Strom
Re: Have no upload button
 

We also have this issue for genuine students logged in.

Our build is moodle 2.3.1+ (20120831)
Enrollment method is via external database.


Resaving the assignment doesn't resolve the issue. These are newly created assignments within 2.3.1 and not upgraded assignments from 2.2 or imported assignments from a back/restore process.

The problem is not consistent. A similar assignment in the same course was providing the submission button to students.

In another course with a similar assignment had the submission button for a period of time and then at a point in time around Sunday evening, the submission button disappeared from the same assignment.

 
Average of ratings: -
Picture of Eric Strom
Re: Have no upload button
 

I created a fresh assignment in the course we had problems with.

The assignment accepted 12 submission and now it is not again. Students see the assignment status of:

"This assignment is not accepting submissions"

 
Average of ratings:Useful (1)
Picture of Nathan Lind
Re: Have no upload button
 

We are seeing after 2 submitted assignments the message, "This assignment is not accepting submissions" appears and students are no longer able to upload a file or online text.

 
Average of ratings: -
Picture of Scott Krajewski
Re: Have no upload button
 

We found our fixes for this one.  Our instance is just this this academic year so all of our classes are imports or new setups.

First, we had Quick Feedback ON and gradebook AJAX OFF.  See http://moodle.org/mod/forum/discuss.php?d=209334

This caused all assignment gradebook items to become overrides. http://tracker.moodle.org/browse/MDL-34363

If the items are overrides students can no longer submit.

While we were at we patched this http://tracker.moodle.org/browse/MDL-35252 which corrected a problem with fixing individual items.

Now we're looking at a mass fix.  We'll be testing within courses.  It appears that removing the override on an item that has been graded is not a good strategy - the grade for that item no longer appears in the gradebook, but does appear when grading the individual student.

But since we're not worried about students who have been graded -- they likely submitted already, we just want to find all items that are overrides and are not graded.  We can find them with

select
i.courseid, g.overridden, g.userid, i.iteminstance, i.itemname, g.rawgrade
from mdl_grade_grades g, mdl_grade_items i
where
g.overridden <> 0
and
g.itemid = i.id
and
g.rawgrade is NULL

 

We can update with

update mdl_grade_grades g, mdl_grade_items i
set g.overridden = 0
where
g.itemid = i.id
and
g.rawgrade is NULL

 

we can restrict that to course (XX) with

and

i.courseid = XX

and even assignment YY with

and
i.iteminstance = YY

 
Average of ratings:Useful (3)
Picture of Vicki Dunnam
Re: Have no upload button
 

We are having the same issues.  IT seems the assignment works and then after students submit, the the assignment becomes overridden so students cannot submit.

Have you fixed this issue?  Will upgrading to new update of Moodle 2.3+ will that help?  

 
Average of ratings: -
Picture of Bret Miller
Re: Have no upload button
Group Particularly helpful Moodlers

We are having the same issue with Moodle 2.31+. The select and update statements above fixed the particular assignment with the problem.

 
Average of ratings: -
Picture of Ellen Kinsel
Re: Have no upload button
 

Your solution worked for us. Would like to know the exact sequence of events that triggers the problem in the first place. We encountered it in two different cases:

1) Restored an archived gradebook to a course

2) Manually entered a mark in a different course (not sure about this but suspect this was what happened)

 

 
Average of ratings: -
Picture of Nancy K Hoke
Re: Have no upload button
 

Greetings Scot, I have just encountered this issue. We are in Moodle 2.3.2+ and I had a faculty member report that students could not submit to the Assignment. I checked all settings (they were fine)  and then went to the gradebook - where the column was tan and all students had been set to Override. i have unchecked the override and sent your information in this discussion to the IT staff. 

There is another Assignment due next week and the override is checked in for all students.  However, the Assingments she created for Week of Nov 19  are all fine.

My question is - is this still an issue that the Moodle developers are working on?  Are there special instructions I should provide to my faculty - especially the English faculty - regarding creating a new assignment?  Thank you for your help - Nancy K. Hoke

 
Average of ratings: -
Picture of Nancy K Hoke
Re: Have no upload button
 

I just checked with the faculty member and all the assignments were new creations - she was in IE when creating the assignments. 

 
Average of ratings: -
Me!
Re: Have no upload button
Group DevelopersGroup Moodle HQGroup Particularly helpful MoodlersGroup Testers

Hi Eric, Can you check the gradebook for one of these assignments and see if all the grades are locked ?

 
Average of ratings: -
Picture of Eric Strom
Re: Have no upload button
 

Damyon,

Yes, this did occur. Scott K's comments are referring to our installation (we are at the same institution). smile

 
Average of ratings: -
Picture of Paul Mohabir
Re: Have no upload button
 
Eric
 
Average of ratings: -
Picture of Paul Mohabir
Re: Have no upload button
 

Eric,

I had this same issue and found the problem. If the assignment is already graded for that student, he would see this status in the assignment. For me the problem was that the student had not yet submitted the assignement and was graded with a zero. So when he was ready to submit the assignment he saw the status "This assignment is not accepting submissions". In order to correct this I had to remove the grade for that student in the gradebook as well as uncheck the override checkbox for that cell. Note, the option to check to uncheck the override button can be found after clicking the edit icon next to the individual grade cell in the gradebook. After doing this, the student is allowed to submit assignments. I hope this helps.

 
Average of ratings: -
Picture of Frank B
Re: Have no upload button
 

Thanks, ERIC! +1

That fixed it for me.

But you would think that would be part of the RESET process of a course.

 
Average of ratings: -
Picture of Andrew Steinman
Re: Have no upload button
 

We just ran into this same issue with our Moodle server (2.3.2). I'm not exactly sure what is causing this issue, but I found a solution that seems to be working.

I unenrolled all of the students from the course and reenrolled them. While that sounds very straight forward, there was one extra step I had to take. To reenroll the students, in the course I went to the Settings block -> Course administration -> Users -> and clicked on Enrollment methods. On the Enrollment methods page, I clicked on the Enroll users icon ().

From there, I was able to successfully reenroll all of the students and all of them now have the "Add submission" button.

*Note: When I tried to reenroll students from the Enrolled users page, I received a syntax error, which didn't prevent me from enrolling the students, but it did not for the upload button problem.

 
Average of ratings: -
Picture of Kal Jordan
Re: Have no upload button
 

Andrew - you don't usually have to go to such lengths to solve that problem. For "This assignment is not accepting submissions" in 2.2, the problem can usually be solved by:

1) going to the main grader report

2) turn editing on

3) find student in list

4) find problem assignment

5) click on *edit grade* cog icon

6) uncheck the *overidden* box

7) save changes

hope this helps

 
Average of ratings: -
Picture of Lienq Van Rooyen
Re: Have no upload button
 

Good day All,

We are using 2.4 and I cannot see the submit button either. I have logged in as administrator, student, teacher, etc. Even our geniun students does not have the button. I went over my setting a 100 times. And it is for ALL the assignments in ALL the courses.

Could it be a bug on 2.4? We are in assignment submission week and students are queing in front of my desk, please help!

 

THX

 
Average of ratings: -
Ben talking on the phone beside a monitor
Re: Have no upload button
Group Particularly helpful MoodlersGroup Testers

Obviously, from everything said above check

  1. That all assignments are not locked
  2. That all assignments either do not have due dates or that the due dates began yesterday and end next Sunday
 
Average of ratings: -
Picture of marilene menezes de figueiredo
Re: Have no upload button
 

thank you Andrew. We solve the issue. 

 
Average of ratings: -