General help

Need to Upgrade from from 1.9.2+ to Current Moodle

 
 
Picture of Myrrh Lynn
Need to Upgrade from from 1.9.2+ to Current Moodle
 

Hello Moodle Friends! After a year's hiatus from the educational world, I have been summoned back to my former job as 'jack-of-all trades'. I left our Moodle 1.9.2+ in the hands of someone who has made ZERO updates or upgrades since then. So, where do I need to post to get help with the tedious job of making our Moodle current?

Please read my profile for my specs. I am not a programmer, I am a teacher, and after being gone for so long, I  have probably forgotten more than I learned about Moodle to begin with. So, please be patient with me.

The Moodle Community has never failed me and has always been helpful and friendly. I just wish my ex-replacement had realized this, so I wouldn't have so much work to do now!

Good to be back! Any takers?

 
Average of ratings: -
Tim at Lone Pine Koala Sanctuary
Re: Need to Upgrade from from 1.9.2+ to Current Moodle
Group DevelopersGroup Documentation writersGroup Particularly helpful Moodlers

Well, first upgrade to 1.9.13.

Remeber the general principles (Upgrading). Backup first (and know how to restore it).

Then, think about upgrading to 2.1.x, but that requires more thought becuase the interface has changed quite a lot, and you need to prepare your users. Also, you will need to upgrade to PHP 5.3.x before you upgrade to 2.1.

 
Average of ratings: -
Picture of Myrrh Lynn
Re: Need to Upgrade from from 1.9.2+ to Current Moodle
 

Hi Tim! Good to see you are still with the community! I've seen the names of some of the 'old guard' as well; glad to see they are still around, too.

Are there any versions between v1.9.2+ and v1.9.13  that I should upgrade to first or can I go directly to v1.9.13?

I am on a hosted server. I have asked if it is possible to upgrade the PHP. They said it was not available at this time. So I may be stuck at v1.9.13 for a while. 

With the PHP limtation, would it be better to stay at my current stable version or would it be better to go ahead and upgrade to v1.9.13?

In other words, are there any drawbacks to the upgrade?

Also, where is the Moodle doc about the 2.1.x interface? (may as well read up on it while I wait for the PHP upgrade) I have looked, but have not found it yet. It has been so long since I have been to the site, I very well could be looking in the wrong place.

Thanks for the help!

 
Average of ratings: -
Tim at Lone Pine Koala Sanctuary
Re: Need to Upgrade from from 1.9.2+ to Current Moodle
Group DevelopersGroup Documentation writersGroup Particularly helpful Moodlers

You should always be able to upgrade from any point on a stable branch to the latest version on that stable branch, so 1.9.2+ -> 1.9.13+ is fine.

And you should plan to regularly upgrade to the latest version of whichever stable branch you are on, to get the latest security fixes. There should be no drawbacks. However, it is always wise to read the release notes: http://docs.moodle.org/dev/Releases#Moodle_1.9

Moodle 2.0 docs start at http://docs.moodle.org/20/en/Main_Page

Also, you could download one of the compete install packages and try it out on your own comptuer, just to start getting the feel of it.

 
Average of ratings: -
Picture of Mike Chalmers
Re: Need to Upgrade from from 1.9.2+ to Current Moodle
 

Here's a thread on What's New in Moodle 2:

http://moodle.org/mod/forum/discuss.php?d=176964

 
Average of ratings: -