Repositories

 
 
Picture of AARON ROTH
Invalid json string
 

I just had my server change my max upload size, and now i get the following error

ERROR: Invalid JSON string

Warning: set_time_limit() [function.set-time-limit]: Cannot set time limit in safe mode in /home/eblifegu/public_html/training/repository/repository_ajax.php on line 94 {"nologin":true,"nosearch":true,"norefresh":true,"list":[],"dynload":false,"upload":{"label":"Attachment","id":"repo-form"},"repo_id":3}

 

Anybody have any idea on how to fix this?

 
Average of ratings: -
Picture of Mauno Korpelainen
Re: Invalid json string
Group Particularly helpful Moodlers

You could check first from php info or php.ini that safe mode is not on ( safe_mode = On in php.ini or PHP is compiled with --enable-safe-mode )

Safe mode must be OFF - otherwise php function set_time_limit() has no effect.

 
Average of ratings: -
Picture of zo bitu
Re: Invalid json string
 

I have the same problem.
not find a solution.
the problem persists.

ERROR: Invalid json string{"nologin":true,"nosearch":true,"norefresh":true,"list":[],"dynload":false,"upload":{"label":"Adjunto","id":"repo-form"},"repo_id":3}

 
Average of ratings: -
Picture of zo bitu
Re: Invalid json string
 

it is solved.

the file was not php.ini.

create a file .htaccess (php_value auto_append_file none)

smile

 
Average of ratings: -
Picture of James Richroath
Re: Invalid json string
 

Where did you create the htaccess file?

 
Average of ratings: -
Picture of Graham Clark
Re: Invalid json string
 

I'm using Moodle 2.0 (Build: 20101130) and am getting the "Invalid JSON String" error message when I try to upload a SCORM package.

Here's what the error message actually says:

ERROR: Invalid JSON string

Internal Server Error The server encountered an internal error or misconfiguration and was unable to complete your request. Please contact the server administrator, webmaster@graccon.com.au and inform them of the time the error occurred, and anything you might have done that may have caused the error. More information about this error may be available in the server error log. Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Also, I went into my cPanel and opened the "Error Log" where I saw this:

[Wed May 18 19:48:00 2011] [error] [client 118.209.73.134] File does not exist: /home/gracconc/public_html/500.shtml, referer: http://graccon.com.au/moodle/course/modedit.php?add=scorm&type=&course=10&section=1&return=0

Is the information immediately above related to my "Invalid JSON String" error? Can someone please help me with this issue? Thanks.

 
Average of ratings: -
Picture of Paola Cánepa
Re: Invalid json string
 

I have the same problem, I am using moodle 2.0 that I installed from the cpanel, but whem I want to update a file with 15,000kb, I have the same message

ERROR: Invalid JSON string
Internal Server Error
The server encountered an internal error or
misconfiguration and was unable to complete
your request.
Please contact the server administrator,
webmaster@paolacanepa.com and inform them of the time the error occurred,
and anything you might have done that may have
caused the error.
More information about this error may be available
in the server error log.
Additionally, a 404 Not Found
error was encountered while trying to use an ErrorDocument to

Please, what I have to do, to correct this error

Thanks for helping

 
Average of ratings: -
Picture of Paola Cánepa
Re: Invalid json string
 

I try putting no htaccess that line, but the error is still there, 

Maybe I make something wrong, someone can tell me how to put that line no htaccess and in what directory do moodle it may be locatated

thanks!

 
Average of ratings: -
Picture of rob wypych
Re: Invalid json string
 


Hello,

I'm having a similar issue with Moodle 2.4 when attempting to load a file from OwnCloud via WebDav repostory. The Web Dav is set up correctly (using the same path one can asscess it through web browsers).

The error is as follows:

Invalid JSON string<pre> Warning: fsockopen(): unable to connect to [web address here]:80 (Unable to find the socket transport "h t t p" - did you forget to enable it when you configured PHP?) in /home1/ilseccou/public_html/vlp/lib/webdavlib.php on line 163 {"dynload":true,"nosearch":true,"nologin":true,"path":[{"name":"WebDAV","path":"","icon":"h t t p:\/\/[web address here]\/vlp\/theme\/image.php\/brick\/core\/1366341350\/f\/folder-24"}],"list":[],"repo_id":5}</pre>

And here is the content of line 163:

$this->sock = fsockopen($this->_socket. $this->_server, $this->_port, $this->_errno, $this->_errstr, $this->_socket_timeout);

 

I wil appreciate a solution to this issue.

Thanks in advance.

Rob

 
Average of ratings: -