General help

Windows server: Port 80

 
 
Picture of Mark Minary
Windows server: Port 80
 

Hi all,

Can someone confirm for me that moodle uses port 80 by default?

Thanks.

 
Average of ratings: -
Picture of John Wells
Re: Windows server: Port 80
 

Not quite.

The port number is specified in the configuration for your webserver.  In Apache, the httpd.conf file uses these lines to define the listening port:

#
# Listen: Allows you to bind Apache to specific IP addresses and/or
# ports, in addition to the default. See also the <VirtualHost>
# directive.
#
Listen 80
#Listen 12.34.56.78:80

I don't know the particulars for IIS, but it should be fairly straightforward...

 
Average of ratings: -
Picture of Jeff Green
Re: Windows server: Port 80
 

IIS will also use Port 80 by default unless it's been configured to use a different one.

 
Average of ratings: -
Picture of Dean Hutt
Re: Windows server: Port 80
 

you might come across this issue if installing on Windows 7

windows7 runs a service called BranchCache.

A description for BranchCache under services.exe is ‘This service caches network content from peers on the local subnet.’

Run the command ‘netstat -ano’ from the command line will show that port 80 is being used by PID 4.

Looking up PID 4 is the NT Kernel

So Windows 7 seems by default to us port 80.

control of the NT Kernal can be found in the http.sys file

Solution

disable the http.sys service manually via the registry:

1) Launch RegEdit:
2) Go to: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HTTP
3) Add a new DWORD (32-bit) value
4) Name it ‘NoRun’ not including the quotes
5) Double click the new property
6) In the Value data field type ’1′ not including quotes and click OK
7) Re-boot your computer

Apache will start on port 80!

 
Average of ratings: -
Picture of Dean Hutt
Re: Windows server: Port 80
 

Oh one other thing to look at first is that Skype will use port 80 so make sure if you have it installed that you disable or turn off skype.

 
Average of ratings: -
Picture of Marcel Laronde
Re: Windows server: Port 80
 

I closed out skype and I made the changes you suggested and the Apache server still will not run.  Any other suggestions?  I am running windows 7.

 
Average of ratings: -
Ben talking on the phone beside a monitor
Re: Windows server: Port 80
Group Particularly helpful MoodlersGroup Testers

Marcel,

Are you running XAMPP on localhost?

If so, cruise to the server directory and turn on xampp-control.exe to see if MySQL is running.

Also, as a Win 7 machine, you will need to have control of all the folders. So go to security and give yourself the permissions necessary. (Mary Cooch, ignore the bad grammar of that sentence, please.)

 
Average of ratings: -
Picture of Fiona Hobbs
Re: Windows server: Port 80
 

I have been trying to get Moodle to work on my home computer thinking I had to go into the code etc, but exiting Skype has solved my issue. Thanks for posting your comment, a great help.

 
Average of ratings: -
Picture of jay trivedi
Re: Windows server: Port 80
 

If moodle can not support port num 80 becoze of skype or iis you can use 8080 ..change in httpd..8080 instead of 80..

 
Average of ratings: -