Installation help

 
 
Picture of Jeff Ferrell
Install Error: Apache/2.2.17 etc. "not supported"?
 

Hi! Trying to install Moodle 2.0.1 to experiment with, and am encountering this error message:

Web server software (Apache/2.2.17 (Unix) mod_ssl/2.2.17 OpenSSL/0.9.7a mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635) is not supported, sorry.

I'm working on a "reseller" account on a shared hosting server, and have access to php.ini and helpful support.

In order to get the installer to run at all, I had to tweak my lib/setuplib.php file to get over my host's "webserver x" masking. I changed line 725 in that file from:

if (stripos($_SERVER['SERVER_SOFTWARE'], 'apache') !== false) {

to:

if (stripos($_SERVER['SERVER_SOFTWARE'], 'webserverx') !== false) {

That got the install to run, at least, but now with the above error down the pike (immediately after it passed the extension checks, I guess you'd call them...). I hacked that file kind of blind...could that change have broken some other check further along?

Thanks for any advice!

Jeff.

 
Average of ratings: -
Picture of Howard Miller
Re: Install Error: Apache/2.2.17 etc. "not supported"?
Group DevelopersGroup Documentation writersGroup Particularly helpful Moodlers
It's probably fine... this turns up occasionally with "unusual" web servers. Mostly they are just Apache clones so it works fine.

If it had been up to me the behavior would just have defaulted to apache-a-like but it isn't up to me wink
 
Average of ratings: -
Picture of Jeff Ferrell
Re: Install Error: Apache/2.2.17 etc. "not supported"?
 

You're right! Went back to the root directory in my browser and it loaded a new screen and allowed me to finish with the installation. I panicked and forgot my usual computer-tech principle: When something fails, do it again; it may do something different the next time! tongueout Thanks for the kick in the right direction!

 
Average of ratings: -