Installation help

Moodle Installation problem 2.0 PHP memory issue

Picture of sara nmn
Moodle Installation problem 2.0 PHP memory issue

With following error came while Moodle installation

Sorry, Moodle 2.0 requires at least 70MB of PHP memory.
Please contact server administrator to fix PHP.ini memory settings.

How to resolve above issue ?

I have to install  webhost but it can't install so how to install in my webhost ?

Average of ratings: -
moi!!! it is what is is...
Re: Moodle Installation problem 2.0 PHP memory issue
Group Documentation writersGroup Particularly helpful Moodlers

mmm The host is the problem here, they have not allowed sufficient memory usage for PHP.  If you have access to a PHP installation, you will see a section in the php.ini file called "Resource Limits" and in it, there is a line

memory_limit = 128M      ; Maximum amount of memory a script may consume (128MB)

I have mine set to the max, because it suits me, not for any other reason.

There may be a way around this issue, but I am not real sure, I am not sure about the sequence of events at the installation of a Moodle and as it uses memory. (These are highly technical issues, beyond the ken or mortal men, I am afraid.) However, this has a good possibility of working as the overrides should work.

In your root folder there may be a file called .htaccess (If there isn't then you can create one easily in any text editor and do not forget the . for the first character of the name.)  It may start with the lines:

deny from all
AllowOverride None

To which you can add the lines:

php_value memory_limit 128M
php_value upload_max_filesize 50M
php_value post_max_size 50M

This takes care of a number of problems all at the same time. the .htaccess file works with Apache, (and I did read that IIS also uses it, but do not hold me to that) which indicates it should work despite the restrictions placed upon you.

What this means is that you are not allowing Users access to your root directory, which improves your security. You are also denying any external overrides to look at your root directory, but it does not inhibit your php scripts (ie those inside Moodle) in any way. If your host has also restricted uploads then you can override that with limits of your own. Be aware though, 50M is huge and should really only be reserved for multimedia files or upon request. It does not interfere with downloads, only uploads. The ony pain here is that a lot of courses are intensely graphic so the 50MB limit is not a lot, so trying to restore a backup can make that limit a real issue.

Please bear in mind here that it is a courtesy to your host that you discuss this with them BEFORE you do it, and let them know the reasons as to why you need to do this. Most hosts are pretty accommodating, and if yours is not, then I would suggest you time with them is going to be difficult, so I would advise you look elsewhere, for a more co-operative host.

Average of ratings: -
Picture of Jock Grady
Re: Moodle Installation problem 2.0 PHP memory issue

I have had the same issue with installing Moodle 2.0.2, i.e. error message re 70MB of php memory needing to allocated in the php.ini file.

Unfortunately my hosting company won't shift the limit above 64MB as they say that it would degrade services on the shared hosting platform.

I've tried the suggested modifications to the .htaccess file, however am still getting the error message.

My only option now seems to be to change hosting provider.

Average of ratings: -
Picture of Go Base
Re: Moodle Installation problem 2.0 PHP memory issue

I faced a similar problem.
Had to resort to a little hack:

in "install.php" line 84

    $minrequiredmemory = '70M';


    $minrequiredmemory = '60M';


but it works.

Average of ratings: -
Picture of Marinho Júnior
Re: Moodle Installation problem 2.0 PHP memory issue

Hi, you can only change the file PHP.INI in the site root in web host.

Im my case, I download the file (php.ini) and replaced the line:

memory_limit = 60M


memory_limit = 80M

Then, uploaded again.

It works!

That's it!

Average of ratings: -