General help

Windows server: SMTP -> ERROR: Failed to connect to server AND hidden quizzes

 
Picture of Linda Bellomo
Windows server: SMTP -> ERROR: Failed to connect to server AND hidden quizzes
 

After updating from Moodle 1.8.6 to 1.9 , we have a number of issues.

First, when users send messages through the Moodle system, they used to go to their mail. Now we receive the following error:

SMTP -> ERROR: Failed to connect to server: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
 (10060)
ERROR: SMTP Error: Could not connect to SMTP host.
Another issue is that every quiz in the courses we transfered into the new Moodle  is hidden. Is there a setting I am missing somewhere? Right now we are going into every course and unhiding each quiz.
 
Average of ratings: -
Picture of Emmanuel Jaep
Re: Windows server: SMTP -> ERROR: Failed to connect to server AND hidden quizzes
 

Hi,
concerning your SMTP issue, you may start debugging by following the above steps:

  • Go to Site Administration / Server / Email
  • Note down the name of your email server (SMTP Hosts)
  • from the server (from the main console itself or from a remote desktop connection), click on Start
  • click on run
  • type cmd (a DOS command prompt box should appear)
  • in the command prompt, type 'telnet NameOfTheSMTPHost 25' (without the quotes)

the screen should become black.

If it's not the case, and you get an error message, you should probably review the settings of the SMTP hosts (host name and port).

A detailed article concering the use of telnet to troublehoot messaging issue can be found here: http://support.microsoft.com/kb/153119/en-us

 
Average of ratings: -