General plugins

New Virtual Programming Lab (VPL) module

 
Picture of Daniel Creed
MOODLE 3.5 Upgrade for VPL Jail server
 

I am having trouble with my Jail-server for a client. They recently upgraded their moodle to 3.5 and the jail server has failed to work again. The plugin works correctly. I get to this page. I am using ubuntu 17.10. 


It used to work before the upgrade. I spent two days on this issue. I recreated the certificate. When I click on the link it doesn't ask me to accept a certificate. 


Also I dont get an OK page when I go to the server[port]/ok. It just displays the page took too long to respond


Please assist




 
Average of ratings: -
Picture of Garth Brady
Re: MOODLE 3.5 Upgrade for VPL Jail server
 

We are experiencing what I believe is the very same problem.  Basically, the connecting window takes forever to load, then after a long wait the 'Click on the following links (server #) and accept the offered certificate' window appears.  When a user clicks on the server link (Server 10), there is an error that says the server took too long to respond.

This only happened after an upgrade to the latest Moodle 3.5.

 
Average of ratings: -
Picture of Juan Carlos Rodríguez-del-Pino
Re: MOODLE 3.5 Upgrade for VPL Jail server
Plugin developers

Hello Daniel and Garth,
I need the versions of Moodle, VPL, the O.S. running the jail server and the jail server to try to spot the problem reported.

Daniel reported that he can not get an OK page from the jail server. I guess that he has updated the O.S. of the jail server and this may be the problem. Please try setting the FIREWALL parameter of the jail server to 0. I have not tested the jail server with Ubuntu 17.10.

Best regards,
Juan Carlos.

 
Average of ratings: -
Picture of Daniel Creed
Re: MOODLE 3.5 Upgrade for VPL Jail server
 

Hey Juan Carlos 


Thanks for the response 

Far as I know this was we have

Moodle 3.5.1

VPL 3.3.4

Ubuntu 17.10 with the latest jail-system. Which I recently reinstalled


I don't believe the OS was upgraded and it was working before the moodle got upgraded. 

The firewall parameter is set to 0 already. 


Thanks

Daniel


 
Average of ratings: -
Picture of Daniel Creed
Re: MOODLE 3.5 Upgrade for VPL Jail server
 

The good news I figured the issue. It was the hosting provider had a firewall on top of the servers firewall. All is working now. 

Confused me a little as it was upgraded nothing should of changed. 

Thanks

Daniel

 
Average of ratings: -
Picture of Juan Carlos Rodríguez-del-Pino
Re: MOODLE 3.5 Upgrade for VPL Jail server
Plugin developers

Thanks Daniel,

This is good news.

Best regards,
Juan Carlos.

 
Average of ratings: -
Picture of Garth Brady
Re: MOODLE 3.5 Upgrade for VPL Jail server
 

Thanks - interesting that this was our issue as well.  Sorry for the trouble!

 
Average of ratings: -
Picture of Juan Carlos Rodríguez-del-Pino
Re: MOODLE 3.5 Upgrade for VPL Jail server
Plugin developers

Hello Garth,
have you managed to resolve your problem as Daniel did?

Best regards,
Juan Carlos.

 
Average of ratings: -