Installing and upgrading help

Upgrade problem 1.9.3 to 1.9.5

 
Picture of Minas Pachnis
Upgrade problem 1.9.3 to 1.9.5
 
When i upgrade moodle from 1.9.3 to 1.9.5 everything seems to work fine. But when i try to insert a new activity, a resource or even edit an existing one i get blank page.

Same when i'm trying to add a new block, the page is refreshing but the block doesn't appear.

The upgrade has no errors or warnings and i try with both ways: overwrite the existing files and fresh copy of files with my db and config.php.

Any idea what should i look or what may be wrong and i can't add or edit anything?
 
Average of ratings: -
Picture of Minas Pachnis
Re: Upgrade problem 1.9.3 to 1.9.5
 
Forgot to mention that i get this message from 1.9.3 (current version)

WARNING!!! The code you are using is OLDER than the version that made these databases!

***edit: I change back to 1.9.3 on a local server and i notice the same issue, i can't add or change anything, but what is already in works fine.

 
Average of ratings: -
Tim at Lone Pine Koala Sanctuary
Re: Upgrade problem 1.9.3 to 1.9.5
Core developersDocumentation writersParticularly helpful MoodlersPlugin developers
Whenever you get a blank page, the first thing you should do is turn on Debugging to get an error message instead.
 
Average of ratings: -
Picture of Minas Pachnis
Re: Upgrade problem 1.9.3 to 1.9.5
 
Hi Tim, this is what i get from debuuging

Fatal error
: Call to undefined method MoodleQuickForm_hidden::MoodleQuickForm_hidden() in C:\xampp\htdocs\iclass.gr\lib\pear\HTML\QuickForm\element.php on line 363


 
Average of ratings: -
Tim at Lone Pine Koala Sanctuary
Re: Upgrade problem 1.9.3 to 1.9.5
Core developersDocumentation writersParticularly helpful MoodlersPlugin developers
Looking at the code, I can't see anything wrong that might lead to this error. The most likely thing is that you got a bad download, or something like that, so you don't have all the right files on your server. Can you check that out somehow (windiff what is on your server with a fresh download, or something like that)?
 
Average of ratings: -
Picture of Minas Pachnis
Re: Upgrade problem 1.9.3 to 1.9.5
 
I have tow backups of the moodle files, and both returns the same results, but just in case i re-download the moodle directory but i get the same error.

I found this thread http://moodle.org/mod/forum/discuss.php?d=129528

Some ppl have problem with php 5.3 and moodle < 1.9.5 some others don't. Any other suggestions before i downgrade the xampp version to 1.7.1 with php 5.2?
 
Average of ratings: -
Tim at Lone Pine Koala Sanctuary
Re: Upgrade problem 1.9.3 to 1.9.5
Core developersDocumentation writersParticularly helpful MoodlersPlugin developers
Ah. That makes sense. I think the easiest thing is just to use PHP 5.2.x for a while longer.
 
Average of ratings: -
Picture of Minas Pachnis
Re: Upgrade problem 1.9.3 to 1.9.5
 
Thanks Tim, i'll change back to php 5.2 on Monday and i'll post the results.
 
Average of ratings: -
Picture of Minas Pachnis
Re: Upgrade problem 1.9.3 to 1.9.5
 
Everything seems to work fine when i downgrade to php 5.2

Thanks for your time Tim.
 
Average of ratings: -