Skip to main content

Moodle announcements

Moodle 1.9.5 is certified SCORM 1.2 compliant