Installing and upgrading help

installation success...almost

 
This discussion has been locked because a year has elapsed since the last post. Please start a new discussion topic.
Picture of John Mazan
installation success...almost
 
Hi there,

New to Moodle so apologies in advance for what may be a repetitive question.

On a Mac running Leopard (10.5) I've installed Apache 2.2, mySQL 5.1.36 and Moodle 1.9.5. These were all done as a clean install as part of the OS or by downloading and configuring the package.

Everything looks like its working. Am able to login in with Admin and get around fine. The only issue is when I attempt to add a user or a course/ category I select the action only to get a blank page. There is no error message that I can tell and now I'm stuck. I'm able to add theme's, I'm able navigate around except there are blank screens throughout.

Any thoughts on what this might be?

Thanks
jfm

 
Average of ratings: -
Picture of Howard Miller
Re: installation success...almost
Group Core developersGroup Documentation writersGroup Particularly helpful MoodlersGroup Plugin developers
Switch on Debugging. Hopefully, you'll get some error messages rather than the blank page. That will help us (or you) to diagnose the problem.

Let us know how you get on.
 
Average of ratings: Useful (1)
Picture of John Mazan
Re: installation success...almost
 
Thanks for that, sometimes you go so far down a hole that you forget the basics.

I turned on Debugging and recieved the following message several times:

Warning: HTML_QuickForm_element::onQuickFormEvent(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead in /Library/WebServer/Documents/moodle/lib/pear/HTML/QuickForm/element.php on line 363

I also received the following Fatal error at the end of the file:

Fatal error: Call to undefined method MoodleQuickForm_hidden::MoodleQuickForm_hidden() in /Library/WebServer/Documents/moodle/lib/pear/HTML/QuickForm/element.php on line 363
 
Average of ratings: -
Picture of John Mazan
Re: installation success...almost
 
I checked the forums and found that someone suggested adding the date_default_timezone_set() line in the Moodle config file. I've now done that and now the Warning messages have been resolved but the FATAL error continues to persist.

Thanks
jfm

 
Average of ratings: -
Picture of Petr Skoda
Re: installation success...almost
Group Core developersGroup Documentation writersGroup Plugin developers
You are using PHP 5.3, it is not compatible with Moodle 1.9.5, you should upgrade to latest 1.9.5+ at least. I would personally recommend to downgrade PHP to latest 5.2.x instead for now and wait for 1.9.6.
 
Average of ratings: Useful (1)
Picture of John Mazan
Re: installation success...almost
 
Děkuji! I'm glad that this was an issue and not something that I did during the installation. I appreciate the follow up and support.

jfm

 
Average of ratings: -
Picture of leena gour
Re: installation success...almost
 
hi
I have faced the same problem, Initially i thought its a problem of win vista/xp. as you said and tested about the phpversion, but how to downgrade php from 5.3 to lower. B'coz i have used xampp to install package and moodle 1.9.5 saparately.


Thanks a lot for sharing ur experience


 
Average of ratings: -
Picture of leena gour
Re: installation success...almost
 
Problem resolved!!!!!!
Same thing: i have downgraded the version of XAMPP from 7.2 to 7.1, as it has php 5.2 and it worked correctly for moodle-1.9.5 on vista.


Thanks


 
Average of ratings: -
Picture of leena gour
Re: installation success...almost
 
have you tried for Moodle 1.9 with php 5.3?
whether it works?

 
Average of ratings: -
Picture of Steve Lee
Re: installation success...almost
 
I have the weekly release (1.9.5) working with PHP 5.3 without this issue. We recently restored a moodle site which came from a slightly older version of the Moodle code and now have this issue. I would upgrade to the latest release of 1.9.5 and stick with PHP 5.3
 
Average of ratings: -
Picture of jeff sherk
Re: installation success...almost
 

Here is a quick fix to run pre 1.9.6 on php 5.3

http://tracker.moodle.org/browse/MDL-16804

 
Average of ratings: -
Picture of Annie Price
Re: installation success...almost
 

Hi Jeff,

I have taken a look at the quick fix you suggest but have no idea where in the file to place it ... can you help please

Annie

 
Average of ratings: -